[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug with entering Log messages using editor other than vi

From: g murkumar
Subject: Bug with entering Log messages using editor other than vi
Date: Mon, 8 Mar 2004 18:06:44 -0800 (PST)

Background :
PC :Intel Pentium 4
OS :Linux redhat 9
CVS version: 1.11.13 (client/server)
I am using latest sources of stable version

Initially my $EDITOR environment variable was set to

After making changes to a OR many files i do

$cvs commit

the cvs would open a gvim editor window. AND at the
same time say

log message empty or unmodified:
a)abort c)continue e)edit !)use same message for all

I would enter log message exit gvim and
say continue (i tried ! option also)

The problem was that NONE of my log messages were ever
registered even though the
cvs made successful updates of my changes, But i lost
my log messages, when i tried seeing cvs log

Then i thought i'd change my $EDITOR in my .cshrc i
did so and made it 'vi' instead of gvim
...and Voila! the log messages started getting
registered. I didnt even get the

'log message empty or unmodified' error

Is this a bug? I wanted to bring this to the attention
of the developers so that
they may fix it, if it is a bug. If not please advise
what was wrong on my part.

Do you Yahoo!?
Yahoo! Search - Find what youÂ’re looking for faster

reply via email to

[Prev in Thread] Current Thread [Next in Thread]