[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

/#cvs.lock): No such file or directoryctory for <some directory in repos

From: Jim Page -
Subject: /#cvs.lock): No such file or directoryctory for <some directory in repository>
Date: Tue, 17 Aug 2004 17:34:52 +0200

I found a post in an archive regarding this issue which came quite close to
an answer, but not quite. I thought I would share my efforts in case it
saves someone some time. Here is the root of teh original thread:


Running unix/Windows cvs clients on source located on a volume shared
between OSs, shared using either Samba or Windows Services for unix NFS (I
tried both). specifically, unix client: cvs (various versions 1.11.2 up to
the latest stable release, under linux). Windows clients: WinCVS and the
PushOK cvs proxy for VisualStudio. The server is a linux box running cvs
1.11.17, on slackware 9.


Running pretty much any cvs command on a client (unix or windows) results in
something like the following:

... cvs stuff ...
cvs status: Examining .
/#cvs.lock): No such file or directoryctory for `/home/cvsroot/blah
'vs status: failed to obtain dir lock in repository `/home/cvsroot/blah
cvs [status aborted]: read lock failed - giving up


Run dos2unix (or similar) on the CVS/Repository file in the client
directory. Note this problem is on the client, not the server. The problem
is that the DOS EOL at the end of the path in CVS/Repository is interpreted
as part of the path. This may be an incomplete fix, as I am a newvie running
a cvs server, but it seems to have worked for me with no ill effects.


Email the way you want it - scanned for viruses and unwanted content by 

Information regarding this service can be found at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]