[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cvs works fine, but two devs are getting constant errors

From: wild98
Subject: cvs works fine, but two devs are getting constant errors
Date: 10 Jan 2007 14:31:45 -0800
User-agent: G2/1.0

Hi all,

Didn't see anything that matched our circumstances, so figured I'd
start a new post.

We have CVS set up and running very well on a Linux server. Various
developers here at our office use it regularly without any problems.

However, two developers who are working on different folder paths of
the same project are getting errors every day when they try to commit

One of them tried to commit her work and CVS (over TortoiseCVS)
reported she needed to do an update first. When she tried the update
command, she got a bunch of errors saying that files which had not
changed were "in the way" and needed to be moved/removed.

This happened yesterday (and the day before). Basically I start at the
highest point in the folder path, move all files and folders into a
temporary folder, run a CVS update in that folder, then move the data
back, run a CVS update, see that everything was just fine. Move up a
folder level, rinse and repeat until we get down to the base directory
where the files were initially checked out. After a half hour of this,
our cvs update was simply reporting her modified files and a few new
files that her Eclipse editor had created.

So everything was fine yesterday -- she committed her work, and
continued to work. Today, she came into the office, worked away on her
code, tried to do a commit, got the same 'need to update' message, and
upon doing so, sees *again* that a bunch of files are "in the way" and
need to be moved/removed. And she says another developer is getting the
same messages now too.

I''m wondering whether the eclipse editor she's using, which has a CVS
module built into it (but they don't use it, they know to use
TortoiseCVS), is maybe seeing the hidden CVS folders all throughout the
project path and is somehow corrupting the files?

Any ideas on where I can start looking to solve this? I'm a little
under the gun (tomorrow is my last day at this job and getting a
working CVS setup was one of my final jobs).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]