[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS pserver "no such repository" error

From: Jolly Roger
Subject: CVS pserver "no such repository" error
Date: Wed, 28 Feb 2007 19:42:55 GMT

Hi folks,

I'm attempting to set up a cvs pserver on Mac OS X 10.4.

I've installed cvs-1.11.22.tar.gz with the config line:

./configure --without-gssapi --enable-client --enable-password-authenticated-client --enable-server --enable-encryption --with-cvs-admin-group=wheel

The resulting cvs binary is at /usr/bin/cvs.

I created the server repository with "sudo mkdir /usr/local/cvsroot/" followed by a "sudo cvs -d /usr/local/cvsroot init". I verified that "/usr/local/cvsroot/CVSROOT" was created.

I created this "/etc/xinet.d/cvspserver" startup file:

service cvspserver
       disable         = no
       protocol        = tcp
       socket_type     = stream
       wait            = no
       user            = root
       server          = /usr/bin/cvs
       server_args     = -f --allow-root=/usr/local/cvsroot pserver
       groups          = yes
       flags           = REUSE

Then I sent -HUP to xinetd.

When I do a "cvs -d :pserver:address@hidden:/usr/local/cvsroot login", after the password prompt, I get a "no such repository" error:

cvs -d :pserver:address@hidden:/usr/local/cvsroot login
Logging in to :pserver: address@hidden:2401/usr/local/cvsroot
CVS password:
/usr/local/cvsroot: no such repository

I've tried this command with a bunch of different cvsroot paths (/, /usr/local/, /cvsroot, etc.), with the same result.

I logged in with telnet and got:

# telnet localhost 2401
Connected to localhost.
Escape character is '^]'.

cvs [pserver aborted]: bad auth protocol start:

Connection closed by foreign host.

Is there a way to get more verbose diagnostic info from the pserver?

I also created the file "/usr/local/cvsroot/CVSROOT/passwd" since none existed, and added "me:dd.75ERde4GfD" (output from perl -e 'print crypt "password", "dd"', "me" replaced with my actual username) - still the same error.

I've searched Google (web and groups) for an hour or so reading various posts and articles about the "no such repository" error, but haven't found anything I haven't already tried.

Any ideas what i am doing wrong here?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]