[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "No such file"

From: Roe, Kevin L.
Subject: Re: "No such file"
Date: Wed, 31 Mar 2010 09:58:41 -0700

The issue with the "cp" command has been resolved.  My netapp drive was not 
being correctly recognized as such by cygwin.  It was interpreted as a "cifs".  
This has been corrected in Cygwin 1.7.3

However, the original point of this thread was a problem with CVS.  This is not 

To recap:

The situation:
I check out a module of my repository (located on a remote machine) and a 
handful of files do not get downloaded due to the "no such file" error 
described below.  I then try to update the same module and get the same error 
on the same files.  I check it out again and get exactly the same response on 
exactly the same files.
I have checked the permissions on the files in the repository.
I have removed some watches that were on some of the files.

Bottom line:
I have a very repeatable problem with no evidence of a cause I've found.

New information:

I have confirmed that the current CVS (1.12.13) in cygwin is the same as in 
cygwin 1.5.25 
The ssh is different though, old = OpenSSH_5.1p1   new = OpenSSH_5.3p1     
server = OpenSSH_5.2p1, or OpenSSH_4.7p1 depending on the machine.

So I ran the "cvs -t update" command on the file in question.  Doesn't tell me 
anything, but here is the output.

  -> main: Session ID is NrLenMDBO35CD1tu
  -> main loop with CVSROOT=/usr/gapps/AEAG/cvs_modules
  -> open_connection_to_server (:ext:hera:/usr/gapps/AEAG/cvs_modules)
 -> Starting server: ssh hera cvs server
S-> Reader_Lock(/usr/gapps/AEAG/cvs_modules/Utilities)
cvs update: warning: was lost
S-> RCS_Checkout (usr/gapps/AEAG/cvs_modules/Utilities/,v, 
S-> 1.5, , , (function)) server_register(, 1.5, , , , , ) 
S-> Register(, 1.5, , ,  )
S-> fopen(/usr/gapps/AEAG/cvs_modules/CVSROOT/history,a)
cvs update: cannot write ./ No such file of directory
S-> Lock_Cleanup()
S-> rename(CVS/Entries.Backup,CVS/Entries)
  -> close_connection_to_server ()
 -> Lock_Cleanup()

I also tried using the -vvv option on ssh, but got the following error when I 
set CVS_RSH to that:

cvs [update aborted]: cannot exec ssh -vvv: No such file or directory


By setting:
CVS_RSH='C:\Program Files\TortoiseCVS\Tortoiseplink.exe'
alias cvs='/cygdrive/c/Program\ File\ \(x86\)/CVSNT/cvs.exe'

I can get CVS to work.

This is a hack and it works because I'm abandoning the built-in CVS.

Further, the only cvseditor I can get to work is the default "Notepad"

I'd like to get the native CVS working in cygwin.  It is the cleanest solution. 
 Any ideas on where I can go from here?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]