info-gnus-english
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't post to a foreign server


From: Burkhard Perkens-Golomb
Subject: Re: Can't post to a foreign server
Date: Sun, 04 Jul 2004 20:13:39 +0200
User-agent: Gnus/5.110002 (No Gnus v0.2) Emacs/21.3 (windows-nt)

Meanwhile I changed to NoGnus 0.2 but the results are still the same:

On 2 Jul 2004, Kai Grossjohann wrote:

> Burkhard Perkens-Golomb <address@hidden>
> writes:
>
>> C-u C-c C-c still tries to post via the primary server.
>
> Weird.

Same with NoGnus 0.2: C-u C-c C-c posts via the primary server without
asking, C-0 C-c C-c asks for the posting method.

>> But C-0 C-c C-c asks for a posting method: I can say (with
>> completion) "foreign.server (nntp)" but then I get

... and still get with NoGnus 0.2 :-( ...

>> ,----
>> | Sending news via foreign.server using nntp...
>> | 441 posting failed 
>> | Couldn't send message via news: 441 posting failed 
>> `----
>
> This seems to be that Gnus sent the posting to foreign.server but
> that server didn't like your posting.  I guess Gnus can't do
> anything about that :-(

Could be but I don't think it's so simple: I can enter the summary
buffer of the "foreign" group I want to post to, press "a" to make a
new posting and send it with C-c C-c: It works! 

> Can you find the " *server foo*" buffer corresponding to this server
> to see what is sent to the server?  Note that the buffer name starts
> with a space, and thus the buffer is not listed in most buffer
> menus.  Use C-x b to switch to this buffer.

Found this buffer: " *server foreign.server  *nttpd**". But this
buffer is empty!?

>> The old thread I found at google suggests that Gnus understands
>> "nntp+foreign.server:foreign.group" in the field "Newsgroup:". But
>> I don't know enough lisp to see where the function
>> "gnus-post-method" is called to look *how* it is called (there's a
>> variable "gnus-post-method" too; that doesn't make live easier for
>> a lisp novice).
>
> Whee.  Understands.  Hm.  I think that perhaps Gnus should
> understand that notation.  But currently, completion pretends that
> the notation works, whereas in reality it doesn't.  This is my
> fault.

Would it be difficult to implement?

Thanks!

        Burkhard


reply via email to

[Prev in Thread] Current Thread [Next in Thread]