[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [XEmacs] problem with date

From: Sébastien Kirche
Subject: Re: [XEmacs] problem with date
Date: Fri, 07 Oct 2005 13:44:08 +0200
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/22.0.50 (darwin)

At 00:10 on Oct 6 2005, Katsumi Yamaoka said :

[date problem with XEmacs]

> > My best guess is that it is caused by the message-make-date...
> Another guess is that you failed to fully install CVS Gnus.
> messagexmas.el is essential to make XEmacs run Gnus, however it
> won't be installed for Emacs.  I suspect you installed CVS Gnus
> using Emacs first and recompiled them using XEmacs. 

Bingo. That's a clever description of my situation.

Indeed I duplicated my gnus  directory installed for emacs to the xemacs
packages, and byte-recompiled the whole thing.

> You will  probably need to know where  message.elc and messagexmas.elc
> come from. To do that:
> M-x locate-library RET message RET
> M-x locate-library RET messagexmas RET
> If message.elc comes from CVS Gnus and messagexmas.elc comes
> from the XEmacs package, it will naturally happen. 

That's it.

> Otherwise, you can simply grep  the messagexmas.el file for the string
> `message-xmas-make-date'.

I tried  to reinstall a fresh Gnus  from the configure, but  I have some
problems :  even with  the --with-xemacs the  configure script  keeps on
configuring  for emacs.  The point  is that  I am  under OSX  and XEmacs
executable is actually  within a bundle. I  have to study how
the configure script is looking for  the executable to tell him where to

I tried several --xxxdir settings, but i didn't foind the right one yet.

Unless someone with OSX can tell me ?

Thank you for you advices.
Sébastien Kirche

reply via email to

[Prev in Thread] Current Thread [Next in Thread]