[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

gnutls-cli not there after upgrade

From: Laura Conrad
Subject: gnutls-cli not there after upgrade
Date: Sat, 25 Apr 2009 10:29:39 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.91 (gnu/linux)

I had been using a set of lines like this in my .gnus.el:

   (setq smtpmail-starttls-credentials '(("" 587 nil nil))
        smtpmail-smtp-server ""
         smtpmail-default-smtp-server ""
         send-mail-function 'smtpmail-send-it
         message-send-mail-function 'smtpmail-send-it
          smtpmail-smtp-service 587
           smtpmail-auth-credentials '((""

to send mail from gnus via the comcast mail server.

One morning some months ago I woke up and was getting smtp error
messages when I tried to send mail, so I googled the error messages and
ended up adding the following to my .gnus.el, before the
smtpmail-starttls-credentials lines above, based on some post in this

  (setq starttls-use-gnutls t
         starttls-gnutls-program "gnutls-cli"
         starttls-extra-arguments nil)

Yesterday, I upgraded from Ubuntu 8.10 to 9.04, and now when I send
mail, I get a message:

      No STARTTLS program was available (tried 'gnutls-cli')

The mail does seem to get sent, at least when I send a test message to
myself.  But the gnutls-cli program doesn't seem to be there any more.

Is the gnutls program necessary? If so what should the
starttls-gnutls-program be set to?  If it's gnutls-cli, where am I
supposed to get that from?

Laura   ( )

reply via email to

[Prev in Thread] Current Thread [Next in Thread]