[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

solved, my fault (was: gnus-dired does not use gnus anymore bug or featu

From: Uwe Brauer
Subject: solved, my fault (was: gnus-dired does not use gnus anymore bug or feature)
Date: Mon, 14 Dec 2009 14:54:27 +0100
User-agent: Gnus/5.110011 (No Gnus v0.11) XEmacs/21.4.21 (linux)

>>>>> "Katsumi" == Katsumi Yamaoka <> writes:

>>>>> Reiner Steib wrote:
   >> On Fri, Dec 11 2009, Uwe Brauer wrote:

   >>> I am desperate and I am thinking of using the old code.

   >> Please don't.  This is a bug we need to find out why it fails for you.

   > Maybe Uwe has to discover by oneself what function of Gnus starts
   > VM.  If what is started is the Lisp command `vm', one way is to
   > provide the dummy function named `vm' like the following:

   > (defun vm (&rest args)
   >   (interactive)
   >   (error "VM started!"))

   > Evaluate this form by typing `C-x C-e' at the end of the last
   > line.  Type `M-x toggle-debug-on-error RET' to turn it on.  Run
   > `gnus-dired-attach'.  And you will see the function that calls
   > this version of `vm'.  The backtrace may expose the real cause
   > in that single shot.  Otherwise, what you want to do next will
   > be to run edebug on the function in question (that calls `vm').
   > Note that the command that starts VM may not be just `vm' but
   > `vm-something-something'.  Good luck.

Thanks, I will try to see whether that will work.

Meanwhile I scanned my init files and the pkg loaded and indeed in one
of my vm-addons-file there is the culprit:

(defalias 'compose-mail 'vm-compose-mail)
that is from the time I was in love with vm.

Of course debugging vm-dired-attach did not help to find this error.

What I find strange is, that in the older version of gnus-dired-attach
*this* problem did not occur.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]