[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

gnus xemacs gentoo starting problems

From: MDG
Subject: gnus xemacs gentoo starting problems
Date: Tue, 02 Feb 2010 22:01:41 +0000
User-agent: Thunderbird (X11/20100130)

REPOST as message has not shown up

It is possible this problem may be a gnus problem, xemacs problem,
gentoo problem or
something else.

I have set followups to gnu.emacs.gnus as the problem relates to gnus,
but please overide as neccessary.

Problem essentialy is after no problems running gnus I no longer can.

Running gentoo, Xemacs version 21.4.22

(setq load-path (cons  "~/ngnus-0.6/lisp" load-path))
(require 'gnus-load)

Now the first question is should I be able to run ngnus 0.6 under xemacs
21.4.22? in particular should I get any "can not open load file: timer "
messages or similar about mail-utils.

I am assuming an update has broken something somewhere as when I last
fired up gnus a couple of weeks ago things were working fine. I think
xemacs has been updated in the portage tree (which is why I wonder if
the problem could be xemacs or gentoo related,)

I have tried a few things to fix it.

I tried renaming .gnus to see if there was a problem in .gnus maybe I
changed something and forgot, no change here.

I tried running as root did get a different start message problem
loading mail-utils as opposed to timer.

Found a gnus 5.8.6 on this partition and tried to run this, got the can
not load file: mail-utils error (not the timer error) switched back

Tried rebuilding gnus

/configure && make EMACS=xemacs

I then tried running as gnu-emacs, recompiled gnus for emacs and fixed
the add-menu-item in .gnus that caused an error in startup under gnu
emacs and now it starts.

So I then tried recompilimg for xemacs.

but did observe the following during compilation.
hile compiling toplevel forms in file /home/*****/ngnus-0.6/lisp/utf7.el:
  !! File error (("Cannot open load file" "timer"))

Further looking revealed this errror for numerous files all referencing

Found an old copy of xemacs 21.4.21 and tried compiling that, as it has
been some time since I compiled xemacs it is possible I missed something
 but to the best of my knowledge ther is no option under ./configure
that is essential for running gnus, if there is I will add it in and try
recompilimg it, though running under xemacs 21.4.21 does not work.

I also don't seem to be getting any output from (setq debug-on-error t)

it just says loading gnus and does nothing.

which does differ from the output with debugging off, but not realy useful.

I have tried copying files over from gnu emacs, to the lisp direcory and
each time I copy a file the error message changes.

I have also tried re emerging xemacs with all use flags enabled, again
no success.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]