[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

trouble sending email: smtp/startls/gnutls

From: Timothy W. Hilton
Subject: trouble sending email: smtp/startls/gnutls
Date: Sun, 8 Jul 2012 10:30:33 -0600
User-agent: Mutt/1.5.20 (2009-06-14)


I am able to read IMAP mail in gnus from several servers without a
problem.  I am having a lot of trouble sending mail, though, using
authsmtp through either TLS or SSL.

The relevant section of my .gnus is set up like this:
(require 'smtpmail)

(setq starttls-use-gnutls t
      starttls-gnutls-program "gnutls-cli")

(setq send-mail-function 'smtpmail-send-it
      message-send-mail-function 'smtpmail-send-it)
(setq smtpmail-default-smtp-server ""
      smtpmail-smtp-server ""
      smtpmail-smtp-service 465 )
      smtpmail-starttls-credentials '(("" 465 nil nil))
      smtpmail-debug-info t
      smtpmail-auth-credentials '(("" 465 "hilton" nil)))

I've tried both starttls and gnutls; in both cases I get to 
Opening STARTTLS connection to `'...done

and then eventually the connection times out.

It seems like my problem is similar to this:

I've tried everything I can glean from those threads to no avail.

I am able to open a connection using gnutls-cli:


$gnutls-cli --port 465
Resolving ''...
Connecting to ''...
- Certificate type: X.509
 - Got a certificate list of 2 certificates.

 - Certificate[0] info:
 # The hostname in the certificate matches ''.
 # valid since: Mon Jul 25 18:00:00 MDT 2011
 # expires at: Wed Aug  1 17:59:59 MDT 2012
 # fingerprint: AF:C5:14:BB:4E:6A:12:67:9E:65:D0:3A:1E:ED:E3:DF
 # Subject's DN: C=US,ST=New Mexico,L=Albuquerque,O=The University of New 
 # Issuer's DN: C=US,O=Thawte\, Inc.,CN=Thawte SGC CA - G2

 - Certificate[1] info:
 # valid since: Wed May 12 18:00:00 MDT 2004
 # expires at: Mon May 12 17:59:59 MDT 2014
 # fingerprint: 84:84:03:56:10:85:53:ED:9A:CA:60:B5:FA:99:D3:31
 # Subject's DN: C=ZA,O=Thawte Consulting (Pty) Ltd.,CN=Thawte SGC CA
 # Issuer's DN: C=US,O=VeriSign\, Inc.,OU=Class 3 Public Primary Certification 

- Peer's certificate issuer is unknown
- Peer's certificate is NOT trusted
- Version: TLS 1.0
- Key Exchange: RSA
- Cipher: 3DES 168 CBC
- Compression: NULL
- Handshake was completed

- Simple Client Mode:

220 ESMTP CommuniGate Pro 5.2.20
221 CommuniGate Pro SMTP closing connection
- Peer has closed the GNUTLS connection


Is the unknown issuer/untrusted certificate comment above a problem?
I'm new at this and I'm getting to wit's end; I'd greatly appreciate any


reply via email to

[Prev in Thread] Current Thread [Next in Thread]