[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

sound distortion

From: Haines Brown
Subject: sound distortion
Date: Sun, 15 Feb 2015 14:59:30 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.4 (gnu/linux)

I installed on Debian Wheezy (3.2.0-4-686-pae #1 SMP Debian
3.2.65-1 i686 GNU/Linux) an Asus Xonar DS PCI Express 7.1. It
played beautifully out of the box, but next day it played with
much distortion. I believe the only thing I did after the initial
success was to remove a line in /etc/modprobe.d/alsa/alsa-base.config
with which I tried to 
correct an old card priority problem.

Sound is hopeless distorted. When I play a CD disk with
alsaplayer the sound stutters: sometimes sound amplitude seems
modulated by a sinewave at about 8Hz/sec and sometimes it
stutters or is silent. What I find significant is that when
alsaplayer is stopped, the stuttering continues for a second or
two longer. Does this suggest feedback?

When I play a .wav file with aplay, the sound is a screech. I
installed pulseaudio and it produced no sound at all and so
removed it. Nevertheless pulse shows up:

  $ aplay -L
      Discard all samples (playback) or generate zero samples (capture)
      PulseAudio Sound Server
      Xonar DX, Multichannel
      Default Audio Device
      Xonar DX, Multichannel
      Default Audio Device
      Xonar DX, Multichannel
      Front speakers

The driver for the card is snd_virtuoso:

    # lspci -v
    06:04.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 \
            [Oxygen HD Audio]
    Subsystem: ASUSTeK Computer Inc. Virtuoso 100 (Xonar DX)
    Flags: bus master, medium devsel, latency 32, IRQ 19
    I/O ports at d000 [size=256]
    Capabilities: <access denied>
    Kernel driver in use: snd_virtuoso

Nothing about the card or driver loading is reported by $
dmesg. This perhaps because its earlier portion was overwritten
by subsequent garbage, multiple repititions of:

    sr 4:0:0:0: [sr0]  Sense Key : Illegal Request [current]
    sr 4:0:0:0: [sr0]  Add. Sense: Illegal mode for this track
    sr 4:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 02 00
    end_request: I/O error, dev sr0, sector 0
    sr 4:0:0:0: [sr0]  Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE

 However, that garbage ended and for a day I've not seen any more of it.
 So in place of dmesg I turn to /var/log/boot. A | grep snd returns:

  Thu Feb 12 14:23:18 2015: Loading kernel module snd-ctxfi.

This is strange. Last week I tried to install an Audigi X-Fi
Titanium before I relized it is not supported by Debian. This
snd-ctxfi sounds like its module is loaded for some reason.

  # lsmod
  snd_ctxfi              62598  0
  snd_hda_codec_hdmi     26352  1
  snd_virtuoso           33765  2
  snd_oxygen_lib         27905  1 snd_virtuoso
  snd_mpu401_uart        13299  1 snd_oxygen_lib
  snd_usb_audio          71436  0
  snd_usbmidi_lib        18801  1 snd_usb_audio
  snd_seq_midi           12744  0
  snd_seq_midi_event     13124  1 snd_seq_midi
  snd_rawmidi            22472  3 \
  snd_hda_intel          21786  1
  snd_hda_codec          63477  2 snd_hda_intel,snd_hda_codec_hdmi
  snd_hwdep              12943  2 snd_hda_codec,snd_usb_audio
  snd_pcm                53461  7 \
  snd_page_alloc         12867  3 snd_pcm,snd_hda_intel,snd_ctxfi
  snd_seq                39512  2 snd_seq_midi_event,snd_seq_midi
  snd_seq_device         13016  3 snd_seq,snd_rawmidi,snd_seq_midi
  snd                    42761  19
    snd_hda_intel,snd_rawmidi,snd_usbmidi_lib,snd_usb_audio, \

Don't know if this could be a problem, so unloaded it and
restarted alsa-utils. That had no effect on the problem.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]