[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ‘/ o’ in inbox summary says ‘No old news’, my ticks gone

From: Eric Abrahamsen
Subject: Re: ‘/ o’ in inbox summary says ‘No old news’, my ticks gone
Date: Thu, 12 Oct 2017 12:34:20 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.60 (gnu/linux)

Göktuğ Kayaalp <> writes:

> On 2017-10-12 02:44 +03, Göktuğ Kayaalp <> wrote:
>> On 2017-10-12 02:19 +03, Göktuğ Kayaalp <> wrote:
>>> On 2017-10-11 07:56 +02, Eric Abrahamsen <> wrote:
>>>> Göktuğ Kayaalp <> writes:
>>>>> Hi,
>>>>> i'm kind-of screwed ATM.  I just started Gnus (M-x gnus), and it fetched
>>>>> my new mail online (via mail-sources), but then when I opened my inbox
>>>>> (an nnml folder), my tick marked messages were not listed as such
>>>>> anymore, and ‘/ o’ says ‘No old news’.  When I look at the mail folder,
>>>>> the messages are still there, but I can't access them through the
>>>>> summary buffer anymore.  I made a recursive copy of my mail folder.
>>>>> What's going on?  Thanks in advance.
>>>> If you're still in the running session, you might try a few "undo"s, and
>>>> see if that gets you back into a good state.
>>> Unfortunately no.
>>>> Otherwise, look at the group parameters for your inbox ("G p"). What
>>>> does is say for the "active" entry? That entry is Gnus' idea of how many
>>>> messages are in the group -- if it's gotten messed up somehow, it might
>>>> believe there are no messages in the group. What does it say?
>>> G p buffer shows nil.  I found that the ~/Mail/active file had this
>>> line:
>>>   inbox 1 1 y
>>> and fixed it setting the first ‘1‘ to the number of posts in that group,
>>> then I got my emails back in the summary buffer.  But it keeps
>>> forgetting my ticks when I fetch new mail.  They are absent from the
>>> relevant sexp in the ~/.newsrc.eld file.
>> Additionally, I see that the ‘.overview’ file for ~/Mail/inbox is
>> truncated, and only includes entries for the last dozen-or-so messages.
>> I've tried to regenerate this file with entries for all the messages
>> without success.  When I do ‘/ o’ now, it shows the items in that file
>> first, whatever number I enter to the prompt.  The second time I hit ‘/
>> o’ and enter some number, that many messages are shown.
> It seems that I've solved this with help from an emacs stack exchange
> answer [1], using the command ‘nnml-generate-nov-databases-directory’.
> [1]

Glad you got it solved!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]