[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Mail source problem (?)

From: Jeremy Hankins
Subject: Re: Mail source problem (?)
Date: Sat, 26 Jan 2019 18:42:12 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Eric Abrahamsen <> writes:
> Jeremy Hankins <> writes:
>> Recently (after an update to emacs about a month ago, debian unstable) I
>> started getting a message when checking mail about a mail source error:
>> Mail source (file :path /var/mail/nowan) error (Searching for program). 
>> Continue? (yes or no)
>> This is apparently from my secondary select method meant to pull in
>> localhost mail, and it doesn't seem to be anything obvious like a
>> permissions problem.  It doesn't make any difference whether I respond
>> yes or no, either way mail out of /var/mail is ignored and the rest of
>> my mail is fetched successfully.
>> It's clearly some sort of compatibility issue and I figured I needed to
>> sort through my gnus file and figure out where it was coming from --
>> annoying but no big deal.  And since it's only a small minority of my
>> mail affected it hasn't bugged me enough to pursue it till now.
>> But the annoying thing, apart from the fact that the error is a bit
>> obscure (what program?), is that if I turn debug-on-quit on so as to
>> figure out where the bug is being triggered and why, the message goes
>> away removing my chance to trigger the debugger.
>> Any ideas either a) what the problem fetching local mail is, or b) why
>> debug-on-quit makes the message go away?
> Are you sure it isn't `debug-on-error' you want? Unless you're getting a
> hang when checking mail, and then trying to C-g out of the hang, you
> won't trigger `debug-on-quit'. Maybe try the former?

I tried that but it doesn't trigger debug-on-error, it's just a prompt
that pops up in the minibuffer.  Normally, I'd wait for the message to
pop up and hit C-G, triggering the debugger.  But with debug-on-quit
toggled on, the message never shows up and gnus silently fails to load
mail from that source.  There is mail in the mail spool, and I also
tried deleting and recreating the spool in case something was corrupted
and causing gnus to choke.

Jeremy Hankins <>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]