[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: No gnus connection with emacs-27 SOLVED

From: Colin Baxter
Subject: Re: No gnus connection with emacs-27 SOLVED
Date: Fri, 17 Apr 2020 12:41:00 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)

>>>>> "Colin" == Colin Baxter <> writes:

    Colin> Hello, I can connect to my news groups using emacs-26.3, no
    Colin> problem, but not with emacs-27 (or emacs-28). Has something
    Colin> changed?

    Colin> The relevant (I think!) portion of my ~/.gnus.el is

    Colin> (setq gnus-select-method '(nntp ""))

    Colin> Emacs-26.3 accepts this, but emacs-27 gives the error:

    Colin> Opening nntp server on news...failed: >>> (error news/nntp No
    Colin> address associated with hostname)

I was launching emacs-27 via the "-q" option and then loading settings
via an elisp config file (don't ask me why!). It seems that emacs-27 had
no way of knowing it had to use ~/.gnus.el when receiving a M-x gnus <RET>
instruction. The solution is therefore to either

M-x load-library <RET> ~/.gnus.el <RET>

prior to launching gnus, or to put

(load-library "~/.gnus.el")

in the original elisp config file.

I hadn't realised before that the "-q" switch is such a killer!

Best wishes,

Colin Baxter
GnuPG fingerprint: 68A8 799C 0230 16E7 BF68  2A27 BBFA 2492 91F5 41C8
The sole cause of all human misery is the inability of people to sit
quietly in their rooms.  Blaise Pascal, 1670

reply via email to

[Prev in Thread] Current Thread [Next in Thread]