[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Mtools] Reading label from a large capacity memory card

From: Alain Knaff
Subject: Re: [Mtools] Reading label from a large capacity memory card
Date: Tue, 17 Feb 2009 12:03:12 +0100
User-agent: Thunderbird (X11/20090105)

Simon Large wrote:
> Alain Knaff wrote:
>> Simon Large wrote:
>>>> dd if=/dev/sda1 bs=512 count=1 of=bootsector.bin
>>>> Replace /dev/sda1 as appropriate. (/dev/sdb3 for third partition on
>>>> second SCSI-like device, etc.)
>>> Here are the boot sectors for 2 cards that I tried.
>>> The 2GB card works OK and reports "Volume label is SIMON TEST".
>>> The 8GB card reports "Big disks not supported on this architecture".
>>> Using 3.9.11
>>> Simon
>> I tried it here (mtools-3.9.11-5.fc10.i386), and got no maxsize
>> problem (I did get a different error about the FAT, but that's
>> because I've only the boot sector).  
>> Just to make sure, if you don't mind, could you send me the 15000
>> first sectors (count=15000) of that disk, that should be enough for a
>> successful mlabel on my side.  
> Attached.

Indeed. I can mdir and mlabel that just fine (shows "no label").

> Sounds like it maybe a config problem on my side. I'm compiling for
> arm-linux here to run on an embedded Atmel ARM9 device.
> Simon

I suspect it might indeed have something to do with certain datatypes (such
as long long) being absent on that kind of device. Trying a more recent
compiler might help.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]