[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] jk_init, jk_cp, and Gentoo /lib64 & UID does not hav

From: sleahy
Subject: Re: [Jailkit-users] jk_init, jk_cp, and Gentoo /lib64 & UID does not have a name on RHEL ES 3 - AMD64
Date: Wed, 9 Aug 2006 09:04:01 +0100


I got errors over the last few days after installing jailkit 64bit on a RHEL ES3 AMD64 bit server too.

The error message I was getting was as follows;

*jk_lsh[5342]: uid 502 or gid 505 does not have a name*

Oliver, you mentioned in your reply that the user 502 must not have been mentioned in /etc/passwd, so I checked all of this but

everything was correct.

In the end, it turned out to be that files were missing from the /lib64 directory, '/lib/64/libnss_files*.   It would appear that not all library files are copied over with the jk_init program, so I used jk_cp again to chroot directory from source and then it worked fine.




"Jeffrey Erikson" <address@hidden>
Sent by: address@hidden

08/08/2006 19:01

Please respond to

[Jailkit-users] jk_init, jk_cp, and Gentoo /lib64

I went through the instructions for installing and configuring jailkit found on the website (using both the 2.0 release and the cvs snapshot).  My system is an AMD64 running Gentoo, kernel 2.6.17-gentoo-r4.  When I would try to log in with my jailed user both through ssh and via 'su - username', I wound up with errors like this:
/bin/bash: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

Looking in <chroot>/lib and <chroot>/lib64, it appeared that all the libraries were in place.  After a while, on a whim, I decided to use jk_cp to copy the libs manually (rather than through jk_init as in the install guide).  I got the libs needed for bash copied over, logged in successfully, and tried executing some commands, which of course needed different libs.  I eventually wrote a simple shell script to copy over all the libs from /lib64.  Everything seems to be working.

My question is, did I miss something in the install or is this something weird about AMD64 or Gentoo-specific installs?  I looked through the message archives, but I couldn't find much other than advice to make sure the libs were there (which they appeared to be at first).

BTW, now that I have it working, I love jailkit.  Great work!

Jeffrey Erikson
Jailkit-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]