[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Jailkit-users] sftpg3 and jailkit issue

From: Corey Van Allen
Subject: [Jailkit-users] sftpg3 and jailkit issue
Date: Thu, 02 Aug 2007 09:59:40 -0600
User-agent: Thunderbird (Macintosh/20070716)

Has anyone successfully used sftpg3 with jailkit? I have a client's company that uses this for their sftp client and whenever they try to access our site it fails and I see this in the log.

Jul 31 17:26:01 transfer sshd[19959]: (pam_unix) session opened for user suna by (uid=0) Jul 31 17:26:01 transfer jk_chrootsh[19960]: now entering jail /var/ftp4/sftp for user suna (5237) Jul 31 17:26:01 transfer jk_lsh[19960]: WARNING: user suna (5237) tried to get an interactive shell session (/usr/sbin/jk_lsh), which is never allowed by jk_lsh Jul 31 17:26:07 transfer sshd[19959]: (pam_unix) session closed for user suna

They tested with a different client and it worked fine. I've never had any issues with any of our other client's clients or any of ours. So I don't feel it's a jailkit issue.

The easy solution would be for them to use a "better" client, but they have standardized on sftpg3. Since, they have some size to them, it's difficult to get them to change. They expect us, as little guys, to.

Since it appears to be a commercial-ware client, I haven't found a copy for my own testing. I'm just trying to avoid a battle with the owner expecting me to "just fix it" meaning allow them free range sftp access.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]