[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ring] updating Ring, can't log in

From: Daniel Pocock
Subject: Re: [Ring] updating Ring, can't log in
Date: Thu, 3 Aug 2017 13:19:28 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.2.1

On 02/08/17 18:11, Anthony Léonard wrote:
> Hi,
>> I installed the Ring package on Debian quite some time ago in 2016.
>> This week I took the latest package from unstable, compiled it on a
>> system running stretch and installed it.  Version
>> 20170720.2.5bf0a65~dfsg1-1
>> When I start it, I see a window that says "Account migration
>> required"
> That's because Ring has changed a lot between 2016 and today,
> especially in October/November of last year. It needs to decipher your
> private key archive to make updates to it.
>> I don't remember setting any password but it won't let me proceed
>> without typing a password.
> Something is weird as in the old version, a password wasn't mandatory
> so it should have asked you to create one but not entering a
> preexisting. There's probably a true problem here that we should
> investigate.
>> Also, I don't have any friends added to that Ring account, it was
>> just a
>> test - I would like to remove that account on the Debian system and
>> make
>> it use the RingID currently working on my Android device.
> To delete your account and any other Ring configuration, you can delete
> those folders (with Ring not being running):
>   - ~/.config/ring
>   - ~/.local/share/ring
>   - ~/.local/share/gnome-ring (may not exist)
>   - ~/.cache/ring
>   - ~/.cache/gnome-ring (may not exist)
> On the next start, it will behave like a new fresh install.

I've tried that, but it is still showing "Account migration required". 
This time the "RingID:" field is blank though

Here is the command I used:

rm -rf ~/.config/ring ~/.local/share/ring \
  ~/.local/share/gnome-ring ~/.cache/ring \

Then I tried:

dconf reset -f /cx/ring/

and now it starts.

>> On the Android device, I have Ring from F-Droid, version 20170215
> This version should be ok. You can download a more recent one on Google
> Play if necessary. The F-Droid version is not as much up-to-date due to
> problems on F-Droid side (but I'm not the most knowledgeable about
> what's happening exactly with them).

I don't have Google Play or a Google account on my phone

In the app, I press "Link another device to this account" and it asks
for a password.  I don't remember ever creating a password.  I tried a
couple of passwords and each time it says "Please wait... Publishing new
account information" and after a few seconds "Couldn't unlock your
account using the provided password."



reply via email to

[Prev in Thread] Current Thread [Next in Thread]