[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Ring] Resend Lost Message

From: Nathan Royce
Subject: [Ring] Resend Lost Message
Date: Mon, 11 Dec 2017 23:09:30 -0600

After taking care of some other stuff, I can now get back to the 2 new
issues I've encountered (separate threads)...

Previous "Sending..." messages need to be resent with subsequent messages.

Don't take the following at face value. I tried to reproduce it the
way I thought was the reason, but it's not happening.

Here's how it played out:
My android device on wifi was bootstrapped to my local server.
However, there are times (like this case) where it'll jump from my
server wifi, to my other wifi and can't access the bootstrap.
... or so I thought. Again, trying to reproduce isn't forcing the problem.
Somehow even though I'm connected to that other wifi and bootstrapped
to my local server, messages were still going through, yet I can't
ping my local server from android.
Just tried switching around wifis and dropping wifi and re-enabling.
I managed to reproduce, but can't say as to the cause...

So essentially, from my android, I send a test message to android. "message 1".
It shows as "Sending ..."
I send another message "message2" and it makes it to linux from android.
So at this point only "message2" shows on linux.
If I close gnome-ring and .... you know what? This is just too
sporadic to nail down.

Basically, when I re-opened gnome-ring, "message1" finally came in and
showed and in the correct order in relation to "message2".
But just doing some more testing, there are messages that still aren't
arriving, even with both bootstrapped to bootstrap.ring.cx.

The short of it is this... when a new message is being sent, any
previous messages that are "Sending..." or haven't been acked, should
be resent.
The recipient can check if the incoming message(s) is a duplicate
(message+time, or id) and not redisplay it, but still ack it.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]