[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libcdio-devel] [PATCH] Try ejecting using eject command on Linux

From: Rocky Bernstein
Subject: Re: [Libcdio-devel] [PATCH] Try ejecting using eject command on Linux
Date: Fri, 12 Jun 2015 11:51:58 -0400

I looked at the eject sources. The difference there seems to be that before
the 0x02 code for eject, and 0x01 code for "active" is sent. Both do an
unlock of the cdrom drive first.

(Maybe CDROM's now have a "suspended" state that you need get out of?
Dunno, but see PDF link below)
seems to match the sources I have downloaded from debian.

Page 62 of seems to describe
code 0x01.  So probably the eject branch in  of
libcdio's mmc_start_stop_uni() in lib/driver/mmc/mml_ll_cmds.c  could add
this code.

On Fri, Jun 12, 2015 at 11:28 AM, Thomas Schmitt <address@hidden> wrote:

> Hi,
> >  I tried using its SGIO code in libcdio to no avail, however.
> When using its libcdio transport adapter, libburn sends CDB
>   {0x1b, 0x00, 0x00, 0x00, 0x02, 0x00}
> via mmc_run_cmd(). This ejects the drive tray. I just tried on Debian 6.
> (Of course i first umount(8) my CD if it was mounted as filesystem.)
> Have a nice day :)
> Thomas

reply via email to

[Prev in Thread] Current Thread [Next in Thread]