[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libjit] Endless loop on jit_function_compile

From: Aleksey Demakov
Subject: Re: [Libjit] Endless loop on jit_function_compile
Date: Wed, 18 Nov 2015 11:32:08 +0600

Hi Mario,

> On 18 Nov 2015, at 02:01, Mario Morgenthum <address@hidden> wrote:
> Hey,
> I tried to compile libjit on windows with cygwin64, but it crashed with a 
> segfault on gen-apply (already tried to compile with -O0 and some other 
> options). Now I built it with --host=i686-w64-mingw32 (and i686-pc-cygwin). 
> Dumping a function with jit_dump_function works, but every time I want to 
> compile it with jit_function_compile, the application ends in an endless loop 
> ... even with an empty function. The same application works with os x. Are 
> there any known issues/solutions for this problem?
> Thank you

IIIRC I never tried it with cygwin64, if you will be able to come up with a 
patch, I’d happily apply it. I might try to solve the problem too but it will 
take some time unfortunately.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]