[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libmicrohttpd] Select timeout being set to 0

From: Christian Grothoff
Subject: Re: [libmicrohttpd] Select timeout being set to 0
Date: Sat, 29 Oct 2011 15:09:19 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20111004 Icedove/3.0.11

Dear Jon,

While I cannot exclude the possibility of this being related to uLibc or PPC. In the past, we had a bug in MHD where time-calculations were causing integer underflows if the local system time was a a few seconds after January 1st 1970 (embedded system clock not set...). I've again looked over the code related to timeouts but didn't find that kind of problem anymore.

In any case, I suggest you audit closely the return values you get from 'time' and then timeout calculations MHD does with those. Maybe there is something... (a 'time' that goes backwards would certainly "upset" MHD).

Please let me know if you find something!

Happy hacking!


On 10/28/2011 09:54 PM, Jon Nalley wrote:
Hi Christian,

I am using 0.9.15.  I also tried to reproduce the issue on a "standard" x86
Debian Linux box and was unable to do so.  I am wondering if my issue may be
related to uClibc on the PowerPC 405.


Jon Nalley

On Fri, Oct 28, 2011 at 11:14 AM, Christian Grothoff<address@hidden

Dear Jon,

I've tried (and failed) to reproduce your problem.  I've attached my
modified version of 'minimal_example.c' (modified to use a thread pool).
  When I connect to the server with firefox, the socket stays open (will be
re-used by the browser) but MHD does NOT use any CPU after the page is
served initially.

I do recall a bugs that could cause similar behavior of MHD looping in
older MHD versions (prior to 4.5) and there was also a bug with looping for
up to 1s before 0.9.12.  Which MHD version are you using? (We're currently
at 0.9.15, another release might happen later this weekend.)

Happy hacking!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]