[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libmicrohttpd] Building libmicrohttpd-0.9.55 on RHEL5

From: microhttpd
Subject: Re: [libmicrohttpd] Building libmicrohttpd-0.9.55 on RHEL5
Date: Mon, 25 Sep 2017 08:55:56 +0200
User-agent: Roundcube Webmail/1.2.1

Den 2017-09-21 15:33, skrev Evgeny Grin:
On 20.09.2017 12:16, Svein Olav Bjerkeset wrote:
I am trying to build libmicrohttpd-0.9.55 with support for https on
RHEL5. As I can not even get the demo_https server to work (server demo which uses plain http, works as intended), there must be something wrong
with libmicrohttpd itself or one or more of the libraries it uses.

Running the demo_https server, it seems to start just fine. However when I try to use curl to connect, it just hangs for a long time after which
it comes back with "curl: (52) Empty reply from server".

I does not seem like the "generate_page" callback function is ever
called. I have tried to add the following statement as the first
statement, but I see no output:

    printf ("U=%s, M=%s\n", url, method);

Occasionally, I get a response, with part of the response headers
garbled, indicating that memory was overwritten somewhere. In this case
curl still hangs after receiving the response and I do get output from
the printf-statement above.

As RHEL5 are missing a lot of libraries, or have outdated versions, I
have built most of the dependent libraries myself. Here is a list of the libraries I have built and linked with microhttpd, and the versions I used:

gnutls: 3.6.0 (also tried 3.5.15 with same result)
gcrypt: 1.8.0
libgpg-error: 1.27
p11-kit: 0.23.2
tasn1: 4.12
nettle: 3.3
ffi: 3.2.1
gmp: 6.1.2

Any idea on where to start tracking down this issue?

Best regards,
Svein Olav Bjerkeset

Hi Svein,

First of all, could you use another name in email? Otherwise it may
confuse other users.

Did you use curl on the same machine?
If you use curl came from RHEL5 repo than your curl could be outdated or
could be linked with outdated SSL lib.
As first step I suggest to check connection from another machine with
modern curl. Also try wget.

Broken response headers may indicate broken TLS lib or broken TLS decoding.

Sorry for the email name. It should be corrected now.

I have tried both curl and whether, and they both fail. The results are the same for local and remote connections. I have tried from a RHEL 6.9 server with modern curl/wget and it still fails.

Best regards,
Svein Olav Bjerkeset

reply via email to

[Prev in Thread] Current Thread [Next in Thread]