[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libmicrohttpd] Building libmicrohttpd-0.9.55 on RHEL5

From: Svein Olav Bjerkeset
Subject: Re: [libmicrohttpd] Building libmicrohttpd-0.9.55 on RHEL5
Date: Wed, 27 Sep 2017 16:36:23 +0200
User-agent: Roundcube Webmail/1.2.1

But I suspect that problem comes from outdated RHEL5 GnuTLS lib.
MHD on git master is able to use modern GnuTLS without gcrypt. As next
step I suggest to build latest GnuTLS on RHEL5 and build MHD with modern

I have never used GnuTLS from official RHEL5 repos during the effort to get libmcrohttpd to work on RHEL5. They are just to old.

Today I recompiled GnuTLS 3.6.0 and libmicrohttpd from git. Running ldd on the new gnutls library, it shows no trace og gcrypt. With the new library, demo_https seems to consistantly core dump with a segfault:

(gdb) bt
#0 0x00000031c7a08dd0 in pthread_mutex_lock () from /lib64/ #1 0x00002b9de625d2fc in gnutls_system_mutex_lock (priv=<value optimized out>) at system/threads.c:119 #2 0x00002b9de624bd13 in gnutls_atomic_increment (session=0x13d64e20, priority=0x13d5e440)
    at atomic.h:58
#3 gnutls_priority_set (session=0x13d64e20, priority=0x13d5e440) at priority.c:563 #4 0x00002b9de5ffd5a0 in internal_add_connection (daemon=0x13d64bd8, client_socket=6, addr=0x2b9de88ff050, addrlen=16, external_add=false, non_blck=true) at daemon.c:2321 #5 0x00002b9de5ffdd41 in MHD_accept_connection (daemon=0x13d64bd8) at daemon.c:2953 #6 0x00002b9de5ffe1d8 in MHD_poll_all (daemon=0x13d64bd8, may_block=1) at daemon.c:3681
#7  MHD_poll (daemon=0x13d64bd8, may_block=1) at daemon.c:3786
#8 0x00002b9de5ffefae in MHD_select_thread (cls=<value optimized out>) at daemon.c:4372
#9  0x00000031c7a0683d in start_thread () from /lib64/
#10 0x00000031c6ed4fdd in clone () from /lib64/

The segfault occurs when a connection is made from the client. I tried with curl as the client from RHEL5, RHEL6, RHEL7 and Solaris 10. They all produce the same result.

Best regards,
Svein Olav Bjerkeset

reply via email to

[Prev in Thread] Current Thread [Next in Thread]