[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libmicrohttpd] Release 0.9.58, but configuration summary is 0.9.55

From: silvioprog
Subject: Re: [libmicrohttpd] Release 0.9.58, but configuration summary is 0.9.55
Date: Fri, 8 Dec 2017 14:21:01 -0300

Hi dude! :-)

I'm using git sub-module upgrading it each new MHD release, however tarball can be a better option with AX_SUBDIRS_CONFIGURE().

Thanks for the tip! :-)

On Fri, Dec 8, 2017 at 2:15 PM, Evgeny Grin <address@hidden> wrote:

Hi Silvio,

If I get you correctly, you are asking about proper way to run configure.
I did not use AX_SUBDIRS_CONFIGURE. I could tell you that if you are using tarball, then you do not need to run autoreconf or bootstrap as configure is already generated.
Best Wishes,
Evgeny Grin
08.12.2017 19:46, silvioprog пишет:
Hum... so it seems a problem related to my environment. :-/ I'm going to check again it tonight.

I'm configuring MHD in my project with AX_SUBDIRS_CONFIGURE ...:

AM_COND_IF([WINDOWS], [LDFLAGS="-static -lrpcrt4"], [CFLAGS=""]) # I've declared 'CFLAGS=""' just because when I build my project removing it I've got a crash in my app initialization and I can't understand why :-(

AX_SUBDIRS_CONFIGURE([libmicrohttpd], [[--enable-static=yes],

... because I want to distribute only one DLL file, without any extra DLL files (libgcc_s_dw2-1.dll, libwinpthread-1.dll, libmicrohttpd-12.dll etc.). Do you think I can use AX_SUBDIRS_CONFIGURE() to configure MHD? I'm not sure it is runs the MHD's bootstrap or call something like autoreconf.

On Fri, Dec 8, 2017 at 5:03 AM, Evgeny Grin <address@hidden> wrote:


Make sure that you try sources from official FTP

I've just rechecked and it is 0.9.58:
configure: GNU libmicrohttpd 0.9.58 Configuration Summary:

I tried both and with same result.
Best Wishes,
Evgeny Grin
08.12.2017 5:20, silvioprog пишет:
Hi dudes.

I've upgraded my MHD copy and after configuring it I've got the following summary:

configure: libmicrohttpd 0.9.55 Configuration Summary:
  Cross-compiling:   no
  Operating System:  mingw32
  Threading lib:     w32
  Use thread names:  no
  Inter-thread comm: socketpair
  libcurl (testing): no, many unit tests will not run
  Target directory:  /mingw32
  Shutdown of listening socket
  trigger select:    no
  Use debug asserts: no
  Messages:          yes
  Basic auth.:       yes
  Digest auth.:      yes
  HTTP "Upgrade":    yes
  Postproc:          yes
  HTTPS support:     no (disabled)
  poll support:      no
  epoll support:     no
  sendfile used:     no
  build docs:        no
  build examples:    no

  License         :  LGPL or eCos

I might be wrong, but it should report 0.9.58. 😶

Silvio Clécio

Silvio Clécio

Silvio Clécio

reply via email to

[Prev in Thread] Current Thread [Next in Thread]