[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: building DLLs with libtool and mingW - do I need the -o option to ge

From: Bob Friesenhahn
Subject: Re: building DLLs with libtool and mingW - do I need the -o option to get a *.dll file?
Date: Wed, 18 May 2005 16:40:56 -0500 (CDT)

On Wed, 18 May 2005, Ed Hartnett wrote:

One feature that lead to this this work was that ability (I
understand) of libtool/mingw/cygwin to produce windows DLLs.

In the past we have produced a DLL using a M$ compiler, but I would
like to maintain only one set of configuration files, so using libtool
seems like a real winner.

I have included the AC_LIBTOOL_WIN32_DLL macro in my, and
the -no-undefined and -no-cygwin options in the linker flags.

When I do my make, everything seems to work, and I get a success
returned from make, but there is no .dll file in the
directory. (Although there is a file).

Did it work? Where is my dll?

Libtool behavior under MinGW has not been consistent across libtool versions. Some libtool versions are broken. Last time I checked (maybe three months), the development code targeted for libtool 2.0 worked properly except that libltdl support is broken for static modules. Several of us endured great pain to get to that point.

The testing I have done was always when using the MSYS shell. I have never tried using MinGW subordinate to the Cygwin compiler/shell.

I am currently using a warmed-over early snapshot of libtool 2.0 code. It does build Windows DLLs.

What version of libtool are you using?

Bob Friesenhahn
GraphicsMagick Maintainer,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]