[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Libtool, rpath, and

From: Adam Mercer
Subject: Re: Libtool, rpath, and
Date: Tue, 29 Nov 2011 23:48:05 -0600

On Mon, Nov 28, 2011 at 23:30, Andy Spencer <address@hidden> wrote:

> This seems to be caused by libtool adding a -rpath flag which forces the
> application to use the /usr/lib64 version provided by mesa even though
> has been properly configured to use the nvidia version.

I ran into essentially the same problem on Scientific Linux 6,
essentially libtool sometimes incorrectly determines the system
library paths. I imagine if you look at the sys_lib_dlsearch_path_spec
variable within the libtool script it will state that /usr/lib is a
system library path and not /usr/lib64. Therefore libtool will assume
it needs to pass /usr/lib64 on the command line thereby leading to
this linking problem.

I raised this question a week or so ago and the workaround suggested was to set:

lt_cv_sys_lib_dlsearch_path_spec="/lib64 /usr/lib64"

during configure, this overrides the paths found by libtool and solved
the linking problem for me. Unfortunately this is a hack and ignores
any paths specified in so you may need to tweak this

Hope this is of some help.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]