[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lightning] JIT_FP -> JIT_AP

From: Ludovic Courtès
Subject: Re: [Lightning] JIT_FP -> JIT_AP
Date: Tue, 31 Oct 2006 17:57:42 +0100
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/21.4 (gnu/linux)

Hi Paolo,

Paolo Bonzini <address@hidden> writes:

> From looking at Ludovic's code for SPARC automatic variables (which I
> won't merge as is, but did give precious insights), I think we need to
> free JIT_FP for automatic stack variables.  So I'm renaming JIT_FP to
> JIT_AP all around (doc and code).

Cool.  Why "AP" BTW?

The reason why I used `_JIT_SPARC_FP' instead of `JIT_FP' is that when
`JIT_FP' is defined lightning assumes on-stack parameter passing, which
I didn't want.

Thus, instead of what you propose, I'd have kept `JIT_FP' to denote the
FP register and then have back-ends define


reply via email to

[Prev in Thread] Current Thread [Next in Thread]