[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lilypond-auto] Issue 4191 in lilypond: Patch: Add an "\or" markup c

From: lilypond
Subject: Re: [Lilypond-auto] Issue 4191 in lilypond: Patch: Add an "\or" markup command
Date: Sat, 15 Nov 2014 09:52:36 +0000

Comment #14 on issue 4191 by address@hidden: Patch: Add an "\or" markup command

Thanks. I am not entirely happy with the name of the function (even though it will not cause the sequence "(or " to occur in code and we have other markup commands definitely requiring the markup and normal namespaces to be separate) but don't have any better proposal. Other options like like "find", "first", "any" don't seem like an improvement regarding the almost-but-not-quite semantic match with a preexisting function, and a compound like "\first-non-empty" would be more descriptive but a bit cumbersome.

The main complaint about "\or" is likely that its meaning will only be (almost) obvious to Scheme programmers, and we usually try accommodating users without affinity to Scheme. I cannot in good conscience claim that our markup commands tend to be LaTeX-like (since LaTeX does not permit dashes in command names, and our markup commands use them lavishly) but the namings tend to be more typesetting-oriented than Scheme-oriented as a rule.

Should we establish a buzzphrase for the negative "non-empty" as related to stencils? It might come in handy elsewhere. Something like \first-printing or \any-printable or \find-actual or so seems a bit better than the negative.

One advantage of starting this feature with a more cumbersome name is that going from there to something short and generic is still possible via convert-ly rules, but the reverse is likely to have false positives for automatic conversion.

Though the particular pattern \b\\or\b is only typical for TeX code (where it means something quite different). And if that were a concern, things like \raise and \lower would already be a nuisance.

So in summary: I don't really have a convincing _technical_ argument against the naming of \or (and there is no doubt that its functionality is useful).

Its just that its naming feels odd to me in the context of markups. Make of that what you will.

You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]