[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Modifying multi-measure rests

From: Kim Shrier
Subject: Re: Modifying multi-measure rests
Date: Wed, 09 Oct 2002 16:38:26 -0500
User-agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.0.0) Gecko/20020911

Han-Wen Nienhuys wrote:

You're putting musical information into the backend by copying
measureLength into measure-length, and in general, this decreases the
flexibility of the system. Can you adapt the patch such that the
engraver simply sets a flag (eg. a boolean) in the grob? AFAICT, you
only use measure-length to examine wether it's main_part_ is bigger
than 2.

OK.  Do you have a naming convention I should adhere to or a recomendation
for the name of the boolean.  You are right.  I am only using the value
of measure-length to compare against 2 so a boolean set in the engraver
would do the job.  I was using measure-length since the property was
defined in other contexts and it looked like I was using it for its
intended purpose.  I'll back out my changes and work up a new patch.

I am sending patches against 1.6.5 since that is the version I am using.
I haven't upgraded to 1.7.2 because I haven't had time to update guile
to version 1.6.0 yet.  While I can send patches against 1.7.2, I cannot
test them out yet.

(Also, can you check if you can run make web before submitting? Your
patch doesn't define any documentation for measure-length)

I'll take care of that.  I'll send updates to the documentation for the
final version of the patch.
Kim Shrier - principal, Shrier and Deihl - mailto:address@hidden
Remote Unix Network Admin, Security, Internet Software Development
 Tinker Internet Services - Superior FreeBSD-based Web Hosting

reply via email to

[Prev in Thread] Current Thread [Next in Thread]