[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

compile error: kpsexpand not found

From: Edward Sanford Sutton, III
Subject: compile error: kpsexpand not found
Date: Sat, 14 Feb 2004 18:41:12 -0700
User-agent: KMail/1.6.51

  When building lilypond from CVS, I run ./ 
--with-kpathsea-include=/usr/share/texmf/include/ --with-kpathsea-lib=/usr/
share/texmf/lib/ as one of the steps. Configure and make proceed just fine. 
As my normal user, my path also includes /usr/share/texmf/bin/ in it which 
avoids configure stating 'WARNING: Please consider installing optional 
programs:  kpsewhich' and make failing because it cannot find kpsexpand.
  Once I run make install as root, kpsexpand isnt found (root has a path of /
usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin). Is adding 
kpsexpand to root's path the preferred way to properly resolve this build 
error? The end of make install's output is included below to help point out 
the section of the install phase (would more of the output be helpful?) I 
can't recall always having this issue until some of the last few CVS 
Thanks again,
Ed Sutton 

if [ -f out/lilypond.nexi ]; then chmod a+w out/lilypond.nexi; fi
/usr/bin/python ../../scripts/ -I  -I ./out -I../../input 
-I ../../input/tricks/ -I ../../input/regression/ -I ../../input/test/ 
-I ../../input/tutorial/ -I /home/mirror176/downloads/src/multimedia/
lilypond/CVS/lilypond/mf/out/  -I /home/mirror176/downloads/src/multimedia/
lilypond/CVS/lilypond/mf/out/ --output=./out --format=texi --verbose 
--process="lilypond-bin -I ./input/test -e '(ly:set-option (quote 
internal-type-checking) #t)'" --process='true' lilypond.tely
lilypond-book (GNU LilyPond) @TOPLEVEL_VERSION@
lilypond-book: error: `kpsexpand \$TEXMF' failed (127)
lilypond-book: error: The error log is as follows:
sh: line 1: kpsexpand: command not found
make[2]: *** [out/lilypond.nexi] Error 1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]