[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Several problems with 2.5.27 version on Windows ME

From: Brynne and Russ Jorgensen
Subject: Re: Several problems with 2.5.27 version on Windows ME
Date: Fri, 10 Jun 2005 02:53:29 -0600
User-agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6) Gecko/20040113

I upgraded this evening to 2.5.29, so these comments don't necessarily apply to the 2.5.27 version I originally reported some issues with...

What if you do

    set "a=hi there"
    echo %a%

that's what I tried for 2.5.28

Under WinME, the echo output is

        ECHO is on

like env var a is not set.  But, if you just do


you'll see there is an environment variable whose name is

        "a=hi there"

double quotes and all without any associated value. Probably not what you want! And, it causes problems with - see below.

globally setting the amount of environment memory under Win-ME is more
difficult under Win-ME than Win-95 and Win-98.  They've disabled a
bunch of the old DOS stuff - in particular, I've never found ANYTHING
that can go in config.sys.  Instead, I found instructions on the
internet as follows:

    add the following line to the SYSTEM.INI file (in c:\windows) under

I used the msconfig tool to do this instead of editing by hand...

Do you have a Microsoft URL that we can present in the popup box?

Apparently the CommandEnvSize setting in SYSTEM.INI dates way back to Windows 3.0 and is still supported. So, all the Microsoft URLs I could find would seem to most users to be out of date. I don't know whether you'd want to include this in a popup, but the following URL does a good job of explaining what to do:

2) When running the desktop and start menu LilyPond shortcuts, now
  that LilyPad will actually execute, I get the following error:

File '0:0 "C:/Program
does not exist

So, the command-line parsing in LilyPond looks to need some work.

This should be fixed in 2.5.28, or lilypad-0.0.4.

There are still problems with the lilypad installed with 2.5.29 under WinME. When you run lilypond.exe without any arguments expecting it to start up lilypad.exe on the file, one of two things happen. (Note: I first renamed lilypad-ascii.exe to lilypad.exe... :)) When I run the LilyPond shortcut on the desktop, I just briefly get a dos-box popped up that says "Bad command or file name." but lilypad.exe never shows up. When I run lilypond.exe from a command prompt, lilypad.exe DOES bring up its window, but it gives the following error:

File '0:0 "D:/PROGRA~1/LILYPOND/USR/share/lilypond/2.5.29/ly/".ly' does not exist.

If I right-click on a .ly file and do either "open" or "Edit source...", I get a similar (but not exactly the same) error:

File 'D:\Program Files\LilyPond\usr\share\lilypond\2.5.29\ly\".ly' does not exist

I probably misunderstood exactly what was supposed to be fixed in 2.5.28. As before, I still don't have time to debug it! :)

3) Maybe the biggest additional issue.  With LilyPond 2.4 on windows,
  the resulting PS file could be viewed by gsview.  With this
  version, even though I can run ghostscript by hand to convert to
  PDF and view that way, if I instead use gsview on the PS file, I
  get the following error:


I verified the two '%%BeginFont: ..." files are in the given folders,


I guess that's all for now.  If you have any ideas on further
debugging why the PS isn't being converted to PDF, let me know!

This is hopefully fixed in 2.5.28, as we now use ttftool to embed the

Well, the symptoms are different, but the ps file is still not compatible with gsview. Here's the error I got this time:

> GSview 4.7 2005-03-26
> Unknown in Comments section at line 7:
>   %%DocumentSuppliedResources: font CenturySchL-Roma
> Unknown in Comments section at line 8:
>   %%DocumentSuppliedResources: font PFAEmmentaler-20
> Unknown in Prolog section at line 13:
>   %%Title: CenturySchL-Roma
> Unknown in Prolog section at line 14:
>   %%CreationDate: Fri Nov 22 10:58:15 2002
> Unknown in Prolog section at line 15:
>   %%Creator: frob
> Unknown in Prolog section at line 16:
>   %%DocumentSuppliedResources: font CenturySchL-Roma
> Unknown in Prolog section at line 26:
>   %%EndComments
> Unknown in Prolog section at line 3633:
>   %%DocumentSuppliedResources: font PFAEmmentaler-20
> Unknown in Prolog section at line 3634:
>   %%Title: PFAEmmentaler-20
> Unknown in Prolog section at line 3635:
>   %%Version: @TOPLEVEL_VERSION@
> Unknown in Prolog section at line 3636:
>   %%CreationDate: Thu Jun  9 00:29:42 2005
> Unknown in Prolog section at line 3637:
>   %%Creator: ,,,
> Unknown in Prolog section at line 3641:
>   %%EndComments
> AFPL Ghostscript 8.51 (2005-04-18)
> Copyright (C) 2005 artofcode LLC, Benicia, CA.  All rights reserved.
> This software comes with NO WARRANTY: see the file PUBLIC for details.
> Displaying DSC file D:/Program Files/LilyPond/usr/share/doc/lilypond-2.5.29-1/input/
> Displaying page 1
> %GSVIEW_PDF_MARK: /ANN /Subtype /Link /Action -dict- /Border Error: /typecheck in --length--
> Operand stack:
> --nostringval-- Rect --nostringval-- --nostringval-- 0.0 0.0 0.0 4.98132 0 0
> Execution stack:
> %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- false 1 %stopped_push 1 3 %oparray_pop 1 3 %oparray_pop 1 3 %oparray_pop 1 3 %oparray_pop .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- --nostringval-- 1 --nostringval-- %repeat_continue --nostringval--
> Dictionary stack:
>    --dict:1129/1686(ro)(G)--   --dict:0/20(G)--   --dict:125/200(L)--
> Current allocation mode is local
> Last OS error: No such file or directory
> --- Begin offending input ---
> -box
> } stop-system
> showpage
> --- End offending input ---
> file offset = 0
> gsapi_run_string_continue returns -10

Unfortunately, lilypond.exe in 2.5.29 still isn't generating a PDF file. But, I did find a few bugs that might help get there in 2.5.60...

Using a dos-box, I run the following:

    "D:\Program Files\LilyPond\usr\bin\lilypond.exe" --verbose

There is no output on the console, and I get the following files created:


Looking at example-2.log, the last couple of lines are:

    Converting to `example-2.pdf'...
Invoking `gs -dCompatibilityLevel#1.4 -sPAPERSIZE#"a4" -q -dNOPAUSE -dBATCH -r1200 -sDEVICE#pdfwrite -sOutputFile#"example-2.pdf" -c .setpdfwrite -f ""'...

Although lilypond.exe says 'Invoking gs ...', I never got any output one
way or the other from the gs command, nor did the example-2.pdf file show up.

So, to check whether gs.exe is working, I created a doit.bat script with the following command and ran it from the dos-box:

"D:\Program Files\LilyPond\usr\bin\gs.exe" -dCompatibilityLevel#1.4 -sPAPERSIZE#"a4" -q -dNOPAUSE -dBATCH -r1200 -sDEVICE#pdfwrite -sOutputFile#"example-2.pdf" -c .setpdfwrite -f ""

and got the following output:

    GPL Ghostscript 8.15: Can't find initialization file

I don't know how you do it, but it looks like you're creating gs.exe from the file, so I experimented with gs.bat until I finally got it working. The main problem was with quoting environment variables - see above.

I'm attaching the updated file. Since I don't know how to make it into gs.exe, I can't test whether that fixes the problem of lilypond.exe going all the way from a .ly file to a .pdf file, so I'll wait for the next dot release...

One last weird bug I discovered. If you run lilypond.exe on the file (I just happened to choose it for a test, not realizing that it looks like something lilypond always reads during startup), it looks like you get an infinite loop.


Description: application/gzip

reply via email to

[Prev in Thread] Current Thread [Next in Thread]