[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

'make web' fails (and takes forever)

From: David Bobroff
Subject: 'make web' fails (and takes forever)
Date: Thu, 23 Jun 2005 19:03:35 +0000

I've tried a few times recently to build the web-docs from CVS.  I've
noticed that the build time for LilyPond itself seems to be much shorter
than it used to be.  On the other hand, the build time for the web-docs
seems extremely long.  I tried building the web-docs (after successfully
building LilyPond) from CVS ChangeLog 1.3812  ('release commit') and it
happily chugged away apparently building the website.  After it had been
doing this for over 7 hours I went to bed.  When I got up this morning I
saw this in the console:

lily-2113223659 lily-713981480 lily-381973821 lily-504789110
lily-1895614935 exited unsuccessfully.
Removing `collated-files.texi'
Traceback (most recent call last):
  File "../../scripts/", line 1612, in ?
    main ()
  File "../../scripts/", line 1595, in main
    ly.exit (1)
  File "/usr/src/lilypond/share/lilypond/2.5.32/python/", line
132, in exit
    raise _ ('Exiting (%d)...') % i
Exiting (1)...
make[3]: *** [out-www/collated-files.texi] Error 1
make[3]: Leaving directory `/usr/src/lilypond/input/regression'
make[2]: *** [WWW] Error 2
rm out-www/ out-www/ out-www/puer- out-www/ out-www/
make[2]: Leaving directory `/usr/src/lilypond/input'
make[1]: *** [WWW] Error 2
make[1]: Leaving directory `/usr/src/lilypond'
make: *** [web] Error 2

While it was working I saw that it would take a lot of time at the
points where it was converting to PNG.  I didn't actually time any of
these events but it was on the order of minutes.

My system:

2GHz P4
256Mb RAM
Fedora Core 3


reply via email to

[Prev in Thread] Current Thread [Next in Thread]