[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems with lilypond 2.5.31 under WinME

From: Brynne and Russ Jorgensen
Subject: Re: problems with lilypond 2.5.31 under WinME
Date: Mon, 27 Jun 2005 22:43:50 -0600
User-agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6) Gecko/20040113

Jan Nieuwenhuizen wrote:

Brynne and Russ Jorgensen writes:

When I run lilypond from the desktop, it does not start up lilypad
with the file.  However, if I start a command
shell, cd to the LilyPond usr\bin directory and then run lilypond, it
DOES start up lilypad.  I thought it was a problem quoting spaces in
the install directory, so I uninstalled and re-installed in a
directory without spaces, and it's still not working.  I dug a little
deeper, and I think now that the problem is that lilypond.exe is not
affecting the environment at all.  I put the following batch file in
c:\windows to see what lilypond.exe does to the environment:


   LILYPOND_VERBOSE=1 lilypond

prints changed environment settings.

Didn't work for me. When I cd to lilypond\usr under Windows command prompt and run:


I don't get any output, nor does lilypad start up. For some reason lilypond returns back to the command prompt even though it's still doing stuff in the background - like trying to run lilypad, which I can tell it's doing because a dos-box pops up briefly with an error message something like 'unknown command'.

Now, here comes the REALLY weird part... At the windows command prompt, if I run

bin\lilypond > out.txt

It DOES run lilypad.exe to bring up the "" file! The out.txt file is empty. Any idea why redirecting stdout would have any effect? I can't think of a reason...

If I instead run

bin\lilypond --help > out.txt

Then the contents of out.txt are:

GNU LilyPond 2.5.31
Usage: lilypond [OPTION]... FILE...

Typeset music and/or produce MIDI from FILE.

LilyPond produces beautiful music notation.
For more information, see

  -b, --backend=BACK             use backend BACK (gnome, ps [default],
                                   scm, svg, tex, texstr)
  -d, --define-default=SYM=VAL   set a Scheme program option. Uses #t if VAL is 
not specified
                                   Try -dhelp for help.
  -e, --evaluate=EXPR            evaluate scheme code
  -f, --formats=FORMATs          dump FORMAT,...  Also as separate options:
      --dvi                      generate DVI (tex backend only)
      --pdf                      generate PDF (default)
      --png                      generate PNG
      --ps                       generate PostScript
      --tex                      generate TeX (tex backend only)
  -h, --help                     print this help
  -H, --header=FIELD             dump a header field to file BASENAME.FIELD
  -I, --include=DIR              add DIR to search path
  -i, --init=FILE                use FILE as init file
  -o, --output=FILE              write output to FILE (suffix will be added)
      --no-print                 do not generate printed output
  -p, --preview                  generate a preview of the first system
  -s, --safe-mode                run in safe mode
  -v, --version                  print version number
  -V, --verbose                  be verbose
  -w, --warranty                 show warranty and copyright

Report bugs to address@hidden


Effective prefix: "D:/LILYPOND/USR/share/lilypond/2.5.31"

So, it would seem that LILYPOND_VERBOSE actually does work, but only when there's a command-line argument. The PATH looks like lilypond is added correctly, which I guess isn't surprising given that redirecting stdout magically allows lilypond to execute lilypad.

Note: I tried running

bin\lilypond > nul

but then lilypad doesn't pop up.

I experimented with a few things to see whether the stdout-redirect might be a work-around for the time being since the symptoms are so weird that debugging it might not be cost effective.

First, I changed the lilypond shortcut on the desktop to run:

C:\WINDOWS\COMMAND.COM /C "D:\LilyPond\usr\bin\lilypond.exe" > c:\lilyout.txt

And, when I double-click, lilypad does start up.  Progress at last! :)

Second, I changed the "&Generate PDF..." explorer command for .ly files to run: /C "D:\LilyPond\usr\bin\lilypond.exe" --verbose "%1" > c:\lilyout.txt

And, when I double-click on an .ly file, it actually creates the PDF file! Yeah! However, thinks the world should be DOS-ey, so it munges the ly-file pathname to 8.3, meaning that what should be example-1.pdf actually comes out as EXAMPL~1.pdf.

I'd prefer to re-direct to a file in %TMP% or %TEMP% (which is the Windows standard?), and then remove it once lilypond.exe is all finished to be nice and tidy. And of course, using real WIN32 long filenames would be good. So, if I have some time in the next few days, maybe I'll try to write a front-end that does what I'm using to do right now. Even better would be to use a pipe (if it works), and have the front-end display the results. Probably won't have time, though. :(

Anyway, unless you have an idea how to debug why lilypond.exe isn't able to exec lilypad.exe or gs.exe normally, at least we might get something working with the stdout redirect hack...

On 2nd thought, I do have an off-the-wall possibility of what might be going on. Is there any chance you're linking lilypond.exe with the -mwindows switch? It's been a while, but I seem to recall that switch was for windows applications that use the WinMain() entry point. Since lilypond.exe uses the main() entry point, linking with -mwindows might be causing WinME to get confused.

One last thing on a totally different topic...

I grabbed Scott Joplin's and entertainer-let.pdf off the mutopia web site a while back. If I use lilypond 2.5.31 to generate a new pdf, it's huge. The old was 91KB, the new is 746KB! Viewing with acrobat reader, the quality of both look similar. The old has a smoother brace on the grand piano staff (is that what's it's called? - I'm drawing a blank right this second), and the new has more consistent weight (and not so bold) of staff lines. (I like the old smoother brace and the new less bold staff lines, but of course it's just personal preference). Anyway, I was shocked at the difference in file size. Is this to be expected? I had to convert the .ly file up to 2.5.31 - could that have any effect? I've skimmed the typeset music, and it all looks basically the same.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]