[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems with lilypond 2.5.31 under WinME

From: Jan Nieuwenhuizen
Subject: Re: problems with lilypond 2.5.31 under WinME
Date: Wed, 29 Jun 2005 10:30:07 +0200
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (gnu/linux)

Brynne and Russ Jorgensen writes:

>> Running
>>    LILYPOND_VERBOSE=1 lilypond
>> prints changed environment settings.
> Didn't work for me.  When I cd to lilypond\usr under Windows command
> prompt and run:
> bin\lilypond
> I don't get any output, nor does lilypad start up.  For some reason
> lilypond returns back to the command prompt even though it's still
> doing stuff in the background - like trying to run lilypad, which I
> can tell it's doing because a dos-box pops up briefly with an error
> message something like 'unknown command'.
> Now, here comes the REALLY weird part...  At the windows command
> prompt, if I run
> bin\lilypond > out.txt
> It DOES run lilypad.exe to bring up the "" file!
> The out.txt file is empty.  Any idea why redirecting stdout would have
> any effect?  I can't think of a reason...

This obviously is a bug/incompatibility in the DOS based Windows
versions wrt the console.

> bin\lilypond --help > out.txt
> Then the contents of out.txt are:
>> GUILE_LOAD_PATH="D:/LILYPOND/USR/share/guile/1.7"
>> PANGO_RC_FILE="D:/LILYPOND/USR/etc/pango/pangorc"
> So, it would seem that LILYPOND_VERBOSE actually does work, but only
> when there's a command-line argument.

Yes, you're right, of course.

> I experimented with a few things to see whether the stdout-redirect
> might be a work-around for the time being since the symptoms are so
> weird that debugging it might not be cost effective.

> First, I changed the lilypond shortcut on the desktop to run:
> C:\WINDOWS\COMMAND.COM /C "D:\LilyPond\usr\bin\lilypond.exe" >
> c:\lilyout.txt

> And, when I double-click, lilypad does start up.  Progress at last! :)

Does everyone have write permission in the root?  Also, do you need to
specify the command intepreter?  I don't think these two things will
work on newer windozes.

> And, when I double-click on an .ly file, it actually creates the PDF
> file!  Yeah!  However, thinks the world should be DOS-ey,
> so it munges the ly-file pathname to 8.3, meaning that what should be
> example-1.pdf actually comes out as EXAMPL~1.pdf.


> I'd prefer to re-direct to a file in %TMP% or %TEMP% (which is the
> Windows standard?), and then remove it once lilypond.exe is all
> finished to be nice and tidy.  And of course, using real WIN32 long
> filenames would be good.

Yes, until it works and is tested on Windows XP too, we should not
integrate it.  Also: do you still get an error log in foo.log if you do

    lilypond > lilyout.txt

> On 2nd thought, I do have an off-the-wall possibility of what might be
> going on.  Is there any chance you're linking lilypond.exe with the
> -mwindows switch?  It's been a while, but I seem to recall that switch
> was for windows applications that use the WinMain() entry point.
> Since lilypond.exe uses the main() entry point, linking with -mwindows
> might be causing WinME to get confused.

Yes.  I think that is the right way to build it for XP, it fixes the
popping up of a console window but uses the console if present.

It seems that we encounter *a lot* of bugs/incompatibilities in the
DOS-based Windows versions.  It starts to be a major time sink, and
I'm beginning to wonder if we should support them at all.  The most
problematic thing is the lack of unicode support, it is really
embarassing that we can only support ascii (the English language).

What would people say if we suggested LilyPond users to upgrade from
DOS based Windows systems to something more modern, like Windows XP or
Ubuntu linux, or send tested patches to CVS?

> One last thing on a totally different topic...
> I grabbed Scott Joplin's and entertainer-let.pdf off
> the mutopia web site a while back.  If I use lilypond 2.5.31 to
> generate a new pdf, it's huge.  The old was 91KB, the new is 746KB!



Jan Nieuwenhuizen <address@hidden> | GNU LilyPond - The music typesetter       |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]