[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: download page: small corrections on Debian package versions

From: Heikki Junes
Subject: Re: download page: small corrections on Debian package versions
Date: Wed, 20 Jul 2005 12:09:24 +0300
User-agent: Debian Thunderbird 1.0.2 (X11/20050331)

Jan Nieuwenhuizen wrote:

Mark Van den Borre writes:

* Lilypond 2.4.5 is in Debian etch, the current testing, and in Debian
* Lilypond 2.2.6 ships with Debian sarge, but it's not in Debian sid

Thanks, I fixed these.

P.S. Is anyone working on 2.5/2.6 .debs for Debian sid/etch?

The maintainer has filed a wishlist bug, but there is a gs dependency


Version 8.14 is required by LilyPond, while version 8.15 is already in unstable (alias sid). Seems like this dependency is going to be resolved soon, see on accepting packages from sid to etch.

$ apt-cache policy gs-gpl
Installed: 8.15-1
Candidate: 8.15-1
Version Table:
*** 8.15-1 0
500 unstable/main Packages
100 /var/lib/dpkg/status
8.01-5 0
990 stable/main Packages
500 testing/main Packages

I found an another, a build dependency problem between debian and LilyPond.
Using ./ for Lilypond resulted in:

ERROR: Please install required programs: /usr/bin/fontforge >= 20050624 (installed: 20050502)

This version is not available in debian,
$ apt-cache policy fontforge
Installed: 0.0.20050502-1
Candidate: 0.0.20050502-1
Version Table:
*** 0.0.20050502-1 0
500 testing/main Packages
500 unstable/main Packages
100 /var/lib/dpkg/status
0.0.20041218-0.1 0
990 stable/main Packages

I tried to file an `important` bug on this to debian (shown below).

- Heikki

Package: fontforge
Version: 0.0.20050502-1
Severity: important

When I try to compile latest stable LilyPond (to be included in sid/etch, from source, command './' results in an error:

ERROR: Please install required programs: /usr/bin/fontforge >= 20050624 (installed: 20050502)

I suggest that a newer version fontforge, version 20050624 or later, would be packed in sid/etch.

I am using Debian GNU/Linux 3.1 (sarge), kernel 2.6.11-1-686, and gcc 3.3.5.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]