[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

make install fails with Lily 2.7.x

From: Cameron Horsburgh
Subject: make install fails with Lily 2.7.x
Date: Fri, 18 Nov 2005 22:18:41 +1100
User-agent: Debian Thunderbird 1.0.7 (X11/20051017)

Hash: SHA1

Hi folks,

I've been trying to build my own .deb of Lilypond 2.7 since around about
2.7.14. Back then I tried to use debbuild from within debian/ but that
didn't work too well, and I now understand that those scripts were

So now I'm trying to do it a little more conventionally. I run
'./configure' and 'make' with no apparent difficulty. Then I use
'checkinstall -D' to create the deb (but I get the same result if I use
a traditional 'make install'). I end up with the following error:

- ------------------------------------------------------------------

Compiling cheatsheet.texi...
cheatsheet.texi is up to date.
Processing include: fdl.itexi
Reading fdl.itexi...
Writing snippets...
All snippets are up to date...
Compiling fdl.texi...
fdl.texi is up to date. warning: option --psfonts not used warning: processing with dvips will have no fonts

DVIPS usage:
    dvips -h ./out/lilypond.psfonts ./out/lilypond.dvi
mv ./out/lilypond.texinfo out/lilypond.nexi 2>/dev/null || mv
./out/lilypond.texi out/lilypond.nexi
LANG= makeinfo  --enable-encoding -I ./out --output=./out/
out/lilypond.nexi:179: warning: unrecognized encoding name `utf-8'.
warning: `.' or `,' must follow @xref, not `f'.
LANG= makeinfo  --enable-encoding -I ./out
- --output=./out/ out/lilypond-internals.nexi
out/lilypond-internals.nexi:10: warning: unrecognized encoding name `utf-8'.
- -c -d /usr/local/info/lilypond
- -c -d /usr/local/info/lilypond
install-info --remove --info-dir=/usr/local/info ./out/
install-info(./out/ failed to lock dir for editing! File
try deleting /usr/local/info/dir.lock ?
install-info(./out/ no entry for file `lilypond'.
install-info --info-dir=/usr/local/info ./out/

install-info(./out/ Invalid info entry
make[2]: *** [local-install-info] Error 9
make[2]: Leaving directory
make[1]: *** [install] Error 2
make[1]: Leaving directory
make: *** [install] Error 2

- --------------------------------------------------------------------------

It seems to have problems with the font encoding in listed
lilypond.nexi. I tried editing that file and changed the utf-8 reference
to Latin-1, but I end up (not surprisingly) with other errors.

I have searched the archive and a similar problem was reported in

The replies seem to suggest that the problem was fixed, but apparently not!

For the record, I seem to have all the appropriate packages installed,
including the fonts listed in input/regression/

As a separate question, I only seem to have trouble building the
documentation, which frustrates me somewhat because I use the online
version of the docs anyway. Is there a rule I can use in the 'make' step
which will leave out the documentation? I've tried commenting out stuff
in the Makefile, but I just end up breaking more than I fix.

Thanks in advance...
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Thunderbird -


reply via email to

[Prev in Thread] Current Thread [Next in Thread]