[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Old versions support

From: Mats Bengtsson
Subject: Re: Old versions support
Date: Mon, 22 Jan 2007 13:02:15 +0100
User-agent: Thunderbird (X11/20061206)

Sebastien Morin wrote:
Sebastien Morin wrote:

Not smart enough to convert new \textscript markup text
I have the same error message.

That's why I also tried to remove this \textscript command and the
text following it.
The conversion then works without any error message. But when I
compile the converted .ly file I still have an error message:

$ lilypond
GNU LilyPond 2.6.5
Processing `'
Analyse... Erreur: syntax error, unexpected RESTNAME,
expecting DRUM_PITCH or NOTENAME_PITCH or '>'
                 s R2.>2. | R2. | Erreur: syntax error, unexpected '>'
                <s R2.
                      >2. | R2. |
Erreur: errors found, ignoring music expression 0: AVERTISSEMENT: old relative compatibility not used
Erreur: failed files: ""

Well, that's everything I can say about this problem. As you can see,
it is not just a matter of adding a \version "1.3.94" line at the
beginning of the mutopia file... unfortunately.
It seems that the original author of the .ly file has used some strange construct
that wasnt' anticipated when the corresponding parts of convert-ly were
written. I haven't looked at the full file, but from the error report, it seems that
the simple solution is to replace
<s R2.>2.

Since LilyPond is such a flexible program, it's almost impossible to write a
conversion program like convert-ly that can handle every possible combination of features. It does a good job in most cases and often it's easy to find out
which lines of code that cause a problem. Also, the most strange constructs
in .ly files were often introduced in an attempt to work around a bug or limitation of that LilyPond version, that now has been fixed in the recent LilyPond versions,
which means that you often simply can remove them corresponding lines.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]