|Date:||Sun, 02 Sep 2007 03:38:40 -0700|
|User-agent:||Icedove 220.127.116.11 (X11/20070607)|
Joe Neeman wrote:
I'm not sure how many of these are still a problem, but the main problem I've had in the past is that lilypond depends on versions of other programs that aren't always in a distribution's repositories.Yeah. For example, Debian _still_ doesn't have guile-1.8.2 or higher. Not even in the unstable branch! I think this was released about a year ago. :( If I were to try compiling lilypond, I'd have to compile/install guile myself (either apply the rational bugfix to 1.8.1, or do .2).
On my current machine, I installed guile, ghostscript and mftrace manually before I could build lilypond (and guile also needed to be patched). Ok, so "involved" might be an exaggeration, but lilypond is a little fussy about its build environment.With good reason, I think -- once we find a bug in the underlying libraries, it doesn't make sense to try to work around that bug in our own code. But that does mean that we have to wait a year (or more) before those underlying projects release new versions and get packaged for major distributions.
Cheers, - Graham
|[Prev in Thread]||Current Thread||[Next in Thread]|