[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Membership request for group GNU LilyPond Music Typesetter

From: Carl D. Sorensen
Subject: RE: Membership request for group GNU LilyPond Music Typesetter
Date: Mon, 16 Jun 2008 17:02:08 -0600

Johannes Schindelin <Johannes.Schindelin <at>> writes:

> > >You need to configure your ssh to use the correct private key.  Something
> > >like
> > >
> > >       Host
> > >                User carl_sorensen
> > >                IdentityFile /home/sorensen/.ssh/id_rsa.repo
> > >
> > >into your $HOME/.ssh/config.  Of course, you have to put in the correct
> > >path to your private key.
> > >
> >
> > Thanks for the help.  I have created a .ssh/config file, with an entry
> > as you suggested. I checked to make sure that the SSH key was correct.
> > I tried again to fetch, without success. I got the same error -- it
> > asked me for a password.
> You said that you gave a password when creating the private/public key
> pair.  So this is expected.  The difference should be that this time, it
> is not aking you for the password, but ssh for the private key.
> Unfortunately, you did not paste any output, so I cannot tell.
> > I tried using slogin to connect to  No luck with that,
> > either.
> With slogin, should tell you that it is not a login shell:
> $ slogin dscho <at>
> fatal: What do you think I am? A shell?
>                                        Connection to closed.

Aha -- the problem I had was that I had not given my Fedora box a hostname,
so the username in the ssh public key was address@hidden

Once I named my Fedora box, then the ssh public key had address@hidden,
and git fetch worked properly.

Now that I have the ssh working right, I'll try to figure out the rest of my 
in working with git.

Thanks for your help.  Just helping me see what I should expect to get
if things were working right was important.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]