[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond code/feature freeze for 2.12

From: Matthias Neeracher
Subject: Re: Lilypond code/feature freeze for 2.12
Date: Mon, 22 Sep 2008 18:42:19 +0200

From: "Trevor Daniels" <address@hidden>

John Mandereau Monday, September 22, 2008 12:02 AM

On 2008/09/20 18:49 -0700, Graham Percival wrote:
Forgot something: we should probably add warnings in the docs (or the
download page) about the sorry state of OSX.
10.4 and 10.3: broken lilypond-book and convert-ly.  The broken
convert-ly is particularly unfortunate given the syntax changes between
2.10 and 2.12.
These Python scripts require Python 2.4, which is not provided in 10.3
and 10.4; ideally we should cross-compile Python and ship it in GUB
binaries, but it could be a nightmare to make it possible (I cannot even
compile current GUB right now, so I'm far from being able to do this
within one or 2 weeks).
The only solution on short term is asking users to install Python 2.4 or
2.5 manually; IIRC Python scripts and/or their wrappers also need to be
edited to make them call the right Python, don't they?

Do we -really- want to issue a new stable release
containing masses of syntax changes with a broken
convert-ly for many Mac users?

The MacOS Python pages <> actually have fairly detailed download instructions and binary installers, so as long as the link is included in the documentation, it doesn't seem unreasonable to expect users to install this manually.

In VocalEasel, I have some code which tests for the presence of python 2.4 and if not found shows an alert taking the user to the download page; I'd be happy to donate this to lilypond, but it's written in Objective C++ and thus not directly suitable for inclusion.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]