[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to use git

From: Mark Polesky
Subject: Re: Unable to use git
Date: Wed, 5 Aug 2009 14:00:51 -0700 (PDT)

Reinhold Kainhofer wrote:

> Have you entered a wrong password more than three times? If the server runs 
> denyhosts, it will then add the IP address to /etc/hosts.deny and you won't 
> be 
> able to connect...

I don't ever recall entering a password anywhere except at How can I test for that?

At the suggestion of Johannes, I did "ssh sv", which returned with:
> $ ssh sv
> Last login: Mon Aug  3 23:53:26 2009 from
> You tried to execute:
> Sorry, you are not allowed to execute that command.
> Connection to closed.

Johannes Schindelin wrote:
> Hmm.  That means that the ssh connection actually worked (even
> if you're  not allowed to execute non-git commands).
> Does 'git ls-remote ssh://sv/srv/git/lilypond.git' work?

'git ls-remote ssh://sv/srv/git/lilypond.git' *does* work.
But I don't know what that means for me.

> Other things you can try:
> 1) Make sure that the problem is really ssh-related:
>   -) try to connect to the server with the -v -v -v options manually (i.e. 
> simply "ssh -v -v -v address@hidden"

Well, "address@hidden" didn't work, so I did "address@hidden", and got
a bunch of lines, ending in "Permission denied (publickey)." I
tried "ssh -v -v -v address@hidden > permission.txt" but the
resulting file was empty (don't assume that I know what I'm
doing, by the way). And the console doesn't have a scroll bar
so I can only see 70 or so lines (I think there are a lot more).

> 2) Check if it's a repository-related issue:
>   -) In a different dir start a git clone (you can kill it as soon as it 
> starts 
> downloading, because then it was able to connect, and the problem is in your 
> local repo)

I "threw the baby out" and was able to start a new git clone,
but *not* with SSH. I still can't push, for example.


Trevor Daniels wrote:
> Can you remind us what you have tried
> so far?

Things I've done:
> Re-boot (obviously yes?)
> Delete and rebuild git repository from remotes/origin/master?

I can pull, but not with SSH. I can't push.

Things I've not done:
> Obtain fresh ssh key-pair?
(Johannes said the SSH connection is working.)
> Re-install ssh code?
> Re-install git code?
> Re-install MinGW?
> Installing repository in a different location - ~/ is usual?
> Have you noticed any other peculiarities?

- Mark


reply via email to

[Prev in Thread] Current Thread [Next in Thread]