[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUB log always goes to linux-x86 ?

From: Graham Percival
Subject: Re: GUB log always goes to linux-x86 ?
Date: Mon, 10 Aug 2009 17:35:15 -0700
User-agent: Mutt/1.5.18 (2008-05-17)

On Mon, Aug 10, 2009 at 05:27:15PM -0700, Patrick McCarty wrote:
> On Mon, Aug 10, 2009 at 05:08:51PM -0700, Graham Percival wrote:
> > Tail of target/linux-x86/log/build.log >>>>>>>>
> > <<<<<<<< Tail of target/linux-x86/log/build.log
>   rm -rf target/freebsd-x86/packages/guile*

I tried that, and src/guile/, and status/guile*, and

The first erro rin target/linux-x86/log/build.log is this:

test -z "/usr/lib" || /home/lilypond/bin/mkdir -p
 /bin/sh ../libtool   --mode=install /usr/bin/install -c
libtool: install: error: cannot install
`' to a directory not ending in
make[3]: *** [install-libLTLIBRARIES] Error 1

> > No, that's not a typo -- the attempt to build guile on freebsd
> > ends up writing to target-linux-x86/log (??)
> Hasn't this always been the case?

Hmm.  Maybe?  I haven't noticed it before.

> When I run `make lilypond', the log file is linux-64/log/build.log
> (since I am running a 64-bit OS).  But when I run
>   bin/gub darwin-ppc::lilypond
> the log file is darwin-ppc/log/build.log.

Well, "make lilypond" compiles all the versions.  It's like
running bin/gub darwin-ppc::lilypond; bin/gub
darwin-x86::lilypond; bin/gub freebsd-x86::lilypond;  ...etc

I would have expected the build for each OS/arch to occur in their
own log files.  It's no big deal if they're all in linux-x86
(since that's the host OS), but it just seemed a bit weird to me.

- Graham

reply via email to

[Prev in Thread] Current Thread [Next in Thread]