[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lilycontrib.tcl, was Re: the "r" in "git pull -r"

From: Jonathan Kulp
Subject: Re: lilycontrib.tcl, was Re: the "r" in "git pull -r"
Date: Tue, 11 Aug 2009 06:28:18 -0500

On Tue, Aug 11, 2009 at 4:12 AM, Maximilian Albert <address@hidden> wrote:
2009/8/11 Johannes Schindelin <address@hidden>:

> It actually worked here, twice.
> But you have this wonderful output field in the GUI, what does it have to
> say? I imagine that it gave you some error message or some such (probably
> due to an older Git version that refuses to update the current 'master'
> branch -- which has no commit yet, though).

Sorry, I should of course have posted the output in the first place:

Initialized empty Git repository in /home/username/lilypond/.git/
>From git://
 * [new branch]      master     -> origin/master
warning: You appear to be on a branch yet to be born.
warning: Forcing checkout of origin/master.
Already on "master"
Branch master set up to track remote branch refs/remotes/origin/master.

So it doesn't give an error, just a warning. But AFAIR I have seen
this warning on my non-GUI-based checkouts, too, even though
everything worked fine. BTW, my git version is (the latest one
that Ubuntu 9.04 has to offer).

> So I would like to ask you two things: first, what was the error message
> (there must have been one), and second: could you change the
>        git checkout -b master origin/master
> to
>        git reset --hard origin/master
>        git config branch.master.remote origin
>        git config branch.master.merge refs/heads/master
> ?

Still no luck. :-( The warning is gone, but the result is as before
(directory is empty, 'git status' reports deleted files). Here is the
output of the new script:

Initialized empty Git repository in /home/username/lilypond/.git/
>From git://
 * [new branch]      master     -> origin/master
HEAD is now at 00c6cac Nitpick: ly:spanner-bound grob name slur -> spanner.

Thanks for your help,

P.S.: It would be nice to let the script print a short message when
it's finished so that the user know when to stop waiting. ;-)

I had the same experience as Max when I tried it on Fedora 11. The only thing in there was the .git/ directory. I like the button, though. :)

Jonathan Kulp

reply via email to

[Prev in Thread] Current Thread [Next in Thread]