[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: strange character "\f" found in source

From: Patrick McCarty
Subject: Re: strange character "\f" found in source
Date: Fri, 21 Aug 2009 12:39:38 -0700
User-agent: Mutt/1.5.20 (2009-06-14)

On 2009-08-21, Mark Polesky wrote:
> I found a strange "\f" character on line 2317 of
> define-markup-commands.scm:

Ah, you've discovered the form feed characters.  :-)

In Vim, they are printed as "^L".

> There are more in the same file, on lines 3036, 3082, 3115.
> I tried using savannah's grep on the web to see if there
> are more in the source code, but I can't get a single hit.
> And I got this a lot: "XML Parsing Error: not well-formed".
> I also tried these within the Git Bash, but they don't work
> either:
> grep -i -G \f scm/*
> grep -i -E \f scm/*
> git grep -i -G \f scm/*
> git grep -i -E \f scm/*
> Anyone know how to do this?

With my bash shell, you can type

  git grep "^L" scm/*

where ^L is typed as "C-V C-L".

And I get these hits:



reply via email to

[Prev in Thread] Current Thread [Next in Thread]