[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make -j4 CPU_COUNT=4 doc failure log

From: Graham Percival
Subject: Re: make -j4 CPU_COUNT=4 doc failure log
Date: Tue, 6 Oct 2009 15:43:37 +0100
User-agent: Mutt/1.5.18 (2008-05-17)

(oops, re-send to list)

On Mon, Oct 05, 2009 at 03:43:58PM -0700, Patrick McCarty wrote:
> Honestly, I think this is a Ghostscript problem.  John has reported
> weird compile failures with `-j3', and I suspect Jan has encountered
> them too, since he recently added
>     parallel_build_broken = True
> to the Ghostscript spec.

That has to do with building ghostscript, not using it.

> `make -j3' has *always* been unpredictable for me, and my `make -j4'
> trials of the past three days have been unpredictable.
> The only thing I haven't tried is reverting the `md5 hash change'
> commit, to see if that makes a difference.
> I don't feel like continuing debugging this issue unless we know *for
> sure* that this is a LilyPond build problem.

The maoing problem is that we have maoing hash collisions, quite
possibly due to maoing including the same maoing snippet in
multiple places in the maoing manual.

I tried adding a time.sleep(60) in lilypond-book if it detects a
collision, but ghostscript goes ahead and merrily tries to deal
with the file.  It's something about the way that the makefile
splits things into jobs; apparently adding a sleep() doesn't delay
that job.

The job-thing might be fixed automatically by switching to waf,
but the hash collision in lilypond-book is definitely our problem.

- Graham

reply via email to

[Prev in Thread] Current Thread [Next in Thread]