[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Problem with pushing

From: James Lowe
Subject: RE: Problem with pushing
Date: Tue, 3 May 2011 18:12:01 +0000

From: address@hidden address@hidden on behalf of James Lowe address@hidden
Sent: 03 May 2011 16:57
To: address@hidden
Subject: Problem with pushing

Hello (be gentle),

I have just pushed a change to the CG but forgot to commit some additional 
changes so they didn't get pushed.

So the CG won't compile now.

I know how to fix this, but when I have tried to push these additional fixes I 
get the following message


! [rejected]        master -> master (non-fast-forward)
error: failed to push some refs to 'ssh://address@hidden/srv/git/lilypond.git'
To prevent you from losing history, non-fast-forward updates were rejected
Merge the remote changes before pushing again.  See the 'Note about
fast-forwards' section of 'git push --help' for details.


I've tried to abort and reset (big red button in Lilygit.tcl) and done the 
edits from scratch and created a new patch, but I can't shake this message any 
time I push.

can someone help?


I ended up pushing from my lilydev install at home.

All fixed.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]