[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: git access

From: Ian Hulin
Subject: Re: git access
Date: Tue, 30 Aug 2011 15:23:37 +0100
User-agent: Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20110812 Thunderbird/6.0

Hash: SHA1

Hi all,

I'm still having problems with enabling push access to git.

On Wed 24 Aug 2011 13:52:13 BST, Ian Hulin wrote:
> Hi all, I've been getting problems setting up git push access to
> savanna.
> On 21/08/11 02:41, Graham Percival wrote:
>> My best suggestion is to try sending an email to lilypond-devel 
>> saying exactly what you tried; somebody can probably figure out 
>> what went wrong.
> OK.  I followed the steps in the CG, but then noted the wrinkle
> about using rsa instead of dsa in the mails re updating the CG
> guide.  Here's what I did. 1. Created the dsa key as per CG. (N.B.
> I did not have a ~/.ssh/id_dsa directory) The Key file
> was created in my local directory. 2. Opened the file in gedit and
> screen-scraped the key 3. Went over to Savannah My Account
> Configuration Change: Change Authorized Keys in Firefox and pasted
> the key into the key #1 slot. 4, Clicked the Update button and got
> the Success message at the top of the screen, 5. Waited a bit, got
> a mail message from Savannah robot and then updated the git remote
> url as per CG. 6. Tested with git pull --verbose and got the remote
> end hung up error. 7.
>> Oh, but first wait an hour and try again, because it can take up 
>> to an hour for them to update their servers with the new ssh
>> key.
> Re-tried after 1 hour, and after 24 hours, no joy. :-(
I can't set up the ssh connection properly, does anyone know if this
configuration (which I have enabled on my router - public IP address will cause problems talking to the Savannah server via
ssh?  This is snip from my router's help.

"Block WAN Requests

Block Anonymous Internet Requests is designed to prevent users from
attacking through the Internet. When it is Enabled, the Router will
drop both the unaccepted TCP request and ICMP packets from the
Internet. The hacker will not find the router by pinging the Internet
IP address. Click Disable to allow those packets to get through."


Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


reply via email to

[Prev in Thread] Current Thread [Next in Thread]