[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: convert-ly rules to destencil Flags

From: mike
Subject: Re: convert-ly rules to destencil Flags
Date: Tue, 25 Oct 2011 04:40:33 -0700
User-agent: Roundcube Webmail/0.5.2

On Tue, 25 Oct 2011 11:49:58 +0200, David Kastrup wrote:
Graham Percival <address@hidden> writes:

On Tue, Oct 25, 2011 at 10:56:23AM +0200, David Kastrup wrote:
"address@hidden" <address@hidden> writes:

> git address@hidden:~/lilypond-git$ git rebase origin/dev/staging
> fatal: Needed a single revision
> invalid upstream origin/dev/staging

git branch -r lists nothing? Anyhow: I tried rebasing, deleting and
pushing the branch about an hour ago, and pushing did not work.

I just (well, 30-90 minute ago, can't remember) merged dev/staging
to master using your formula.  That may have impacted things.

Don't think so: I think I rebased dev/staging before that. Afterwards, the merge should have just been a painless fast-forward. Weird, all in

Mike: try the old instructions here to get the branch:

I will work at simplifying these, since we're suggesting that
people go with git clone and those instructions were written in
the pre-clone era.

I see that my git config contains
[remote "origin"]
        fetch = +refs/heads/*:refs/remotes/origin/*
        url = ssh://
        fetch = +refs/heads/dev/staging:refs/remotes/origin/dev/staging

Maybe references in a subdirectory don't get found automagically?  On
the other hand, git branch -r lists a whole lot here.  No idea.

Hey all,

I tried:

git remote add -ft dev/staging -m dev/staging staging git://

And then

git branch foo staging/dev/staging
git checkout foo
git apply foo.diff (where foo.diff are all of my changes)
git commit -a (with the appropriate commit message)
git push

and I get

fatal: The remote end hung up unexpectedly

Any ideas what I did wrong?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]